Okay... so how DO I install Java?

Seriously, I’ve never had to do this before on a personal machine. I’m running Catalina 10.15.7. Yes, I need .doc. No, I can’t make do with .docx. No, I can’t wrap up an RTF inside a .doc shell. It has to be real .doc, and I know from the last time I compiled that I need the Aspose converters.



Does that help?



If you use homebrew, it is as simple as typing “brew install adoptopenjdk” into Terminal. This, incidentally, installs the same distribution of Java that Scrivener was using before.

Thanks for your responses, Mark and Ioa!

Sadly, no, as I’ve already followed that process (Java runtime 8 update 271). But restarting my MacBook after install and opening Scrivener did NOT give me access to any new options in the Preferences->Sharing->Conversions panel:
[attachment=0]Screen Shot 2020-11-20 at 11.41.26.png[/attachment]

Again, sadly, I don’t use Homebrew and don’t know what it is.

Would there be any special incantation (command line) or magic security ritual (strange things checked/unchecked in System Preferences with many entries of passwords) that I need to invoke?

I just upgraded to Scrivener 3.2.1 – no change. (Not that I expected this to change as nothing regarding Java was listed in the changes list, but hope does spring eternal in the draconian breast.)

So how do I convince Scrivener to recognise Java?

That’s strange. I installed Java and Scrivener recognises it. You’re not using the MAS version, are you? It shouldn’t make a difference, but who knows?

Worth knowing about: https://brew.sh.
Makes some operations a lot easier and quicker.

I recommend the homebrew route too. brew is one of the most wonderful and helpful tools on macOS, you can install both command-line, macOS apps, and even fonts keeping them up-to-date and easily managed. I also use the brew install adoptopenjdk, and it installs into a standard location so should be picked up by apps like Scrivener and LibreOffice etc.

But if you don’t want to start on the homebrew route just yet you can manually install adoptopenjdk from here:

adoptopenjdk.net/?variant=openj … nt=hotspot

Java on macOS is currently a hot mess of legacy and modern versions allied to macOS’s weird outmoded wrappers (it offers a “ghost” java that promps to install Java, but that is the ancient Oracle version; since then Java versions have exploded into a multitude of different options and macOS has totally failed to update to this)…

As an offtopic aside, why do you still need .doc? I assume some corporate publishing tool still requires it!? It amazes me how long it takes some legacy anti-accessibility formats to die…

You hit the nail on the head with that one. For https://smashwords.com publication, one can either upload an epub, which won’t be distributed to all their retail partners, or you can upload a .doc plus a cover image, which will be transformed into many different formats (including epub) and will go to all their retail partners. The quality of the .doc-generated epub is perfectly OK, if not especially fancy, and goes to Apple, Barnes & Noble, Kobo, and many others. If you upload an epub directly, the smaller retailers get left behind. (Also, I’ve heard tales of woe on these forums about getting a directly-uploaded epub to pass Smashwords’ tests. I’ve never had a problem with the .doc->epub route.)

No, indeed. I always buy directly if I can, so that’s not it.

Just used your link, and it worked! Thanks, Nontroppo! I’ll look into homebrew sometime later when I’m not trying to write a few thousand words in November… :smiley:

Um… since I seem to have installed Java 8 by means of the Apple link, and the install that worked was Java 15—does anyone have any way to get rid of the “ghost” Java?

Thanks again, all!

It has been ages since I installed the old Oracle 8 Java. If it came as a .pkg installer that you didn’t delete, you could use Pacifist, Suspicious package or UninstallPKG to see where it got installed, but honestly I would just keep it around (I doubt it will cause problems). What does typing java --version in terminal show?

openjdk 15.0.1 2020-10-20 OpenJDK Runtime Environment AdoptOpenJDK (build 15.0.1+9) OpenJDK 64-Bit Server VM AdoptOpenJDK (build 15.0.1+9, mixed mode, sharing)
So no trace of Oracle Java 8. Evidently I dodged that bullet…