old version of wine to run windows scrivener?

Is anyone running scrivener under the wine version from the ubuntu (18.04) software center?? looks like it’s 3.0 (?).

I have run into a couple of issues trying to get the latest version of wine (5.0) installed from WineHQ website, so if the older version works for this, I’m fine with it. I don’t plan to be running any other windows programs, certainly not any graphics-heavy games or anything.

Nope. I use whatever the latest development version of WINE is, plus the staging patches. You might not be gaming with WINE, but it’s a program that’s being continuously improved, and Scrivener benefits, as a result. Like with WINE 5.0 the graphics of Scrivener are much improved, as is font handling. Also, later versions of WINE (4.19 and above) with Scrivener exit cleanly, while older ones don’t. Finally, Scrivener’s licensing server is going to need dotnet 4.6 or so, which absolutely doesn’t work with old versions of WINE.

thanks for the reply.
guess i’ll try again to see if I can get Wine 5.0 working then.

Tested beginning of February 2020, on a fresh install of Ubuntu Mate 18.04.3 LTS and Ubuntu Mate 19.10.

  1. Install Wine 5.0 Stable according to the procedure from this site http://ubuntuhandbook.org/index.php/2020/01/install-wine-5-0-stable-ubuntu-18-04-19-10/

  2. wine --version -> to check the installation

  3. sudo apt install winetricks

  4. sudo apt install winbind

  5. winecfg -> the first launch will fetch and install the latest Gecko and Mono packages from winehq.org

6. winetricks | Select the default wineprefix | Install a Windows DLL or component | speechsdk MS Speech SDK 5.1

  1. wine uninstaller - install the 64bits version of Scrivener, then exit

8. wine uninstaller - you should have the following packages installed :

Microsoft Speech SDK 5.1 - Version 5.1.4324.0
Scrivener - Version
Wine Gecko (32-bit) - Version 2.47.1
Wine Gecko (64-bit) - Version 2.47.1
Wine Mono Runtime - Version 4.9.4
Wine Mono Windows Support - Version 4.9.4

  1. add the Categories info and correct the missing icon with a text editor (gedit/pluma/nano) in the Scrivener.desktop launchers located in


a. Scrivener.desktop
[Desktop Entry]
Exec=env WINEPREFIX="/home/@@@@/.wine" wine C:\\windows\\command\\start.exe /Unix /home/@@@@/.wine/dosdevices/c:/ProgramData/Microsoft/Windows/Start\ Menu/Programs/Scrivener/Scrivener.lnk
Comment=Launch Scrivener
Path=/home/@@@@/.wine/dosdevices/c:/Program Files/Scrivener

b. Uninstall Scrivener.desktop
[Desktop Entry]
Name=Uninstall Scrivener
Exec=env WINEPREFIX="/home/@@@@/.wine" wine C:\\windows\\command\\start.exe /Unix /home/@@@@/.wine/dosdevices/c:/ProgramData/Microsoft/Windows/Start\ Menu/Programs/Scrivener/Uninstall\ Scrivener.lnk
Comment=Uninstall Scrivener
Path=/home/@@@@/.wine/dosdevices/c:/Program Files/Scrivener

@@@@ stands for your username

That’s it, folks !

Addendum to previous post
The Wine Mono package ist the open-source counterpart of the closed-source .NET Framework. Mono 4.9.4 identifies itself as .NET Framework 4.7.2 but it’s still not the real thing and some functionalities may be missing and get you application errors. To correct this, you need to replace the Mono packages with the real Microsoft .NET packages. From the previous post, you need first to update the 18.04 distribution winetricks scripts, then install the .NET package. This is an iterative procedure taken care of by the winetricks scripts, you will have to install several .NET packages, several were written for 32bits version of Windows and will generate warning messages during the installation process, just click them away.

  1. sudo apt remove winetricks
  2. cd Download
  3. wget raw.githubusercontent.com/Winet … winetricks
  4. chmod +x winetricks
  5. sudo cp winetricks /usr/local/bin
  6. winetricks | Select the default prefix | Install a Windows DLL or component | dotnet462 MS .NET 4.6.2

thanks for the replies! I haven’t summoned the will to deal with this yet; but this looks really helpful, so when I do get around to it, hopefully I’ll find success. :slight_smile:

so I made a stupid mistake when following the provided outline, I think I figured out how to fix it. The only concern I have now is that I’ve realized I apparently didn’t completely get rid of folders associated with a previous attempt at running wine via “play on linux” - I still have a folder on my harddrive labeled ‘playonlinux’ and ‘playonlinux’s virtual drive’.
I have run the command:
“sudo apt-get purge playonlinux”

following removing it via the software center and the output says the package ‘playonlinux’ is not installed, so not removed. which is good.
Similarly, I removed the old wine3.6 version that the ‘playonlinux’ was using - removed via the software center, that is. as far as I can tell, I only have Wine5.0 installed - if I search from the command line for installed wine packages the only ones that show up are version 5.0. All good!
But I want to make sure that the “play on linux” virtual drive that’s currently sitting there not doing anything won’t interfere with the Wine5.0 version I’m installing here. What concerns me is the “playonlinux” ‘win’ subfolder that seems to actually have stuff in it.
Can I just manually delete the ‘playonlinux’ folder AND ‘playonlinux’s virtual drive’? I think I did this when I first tried switching over to installing the latest wine and something went haywire, but it’s entirely possible I screwed something else up without realizing it. (it was a new install of the OS, so I just reinstalled rather than try to fix it).

maybe I should split this off into its own topic but it’s a fallout of my own inexperience and not directly related to scrivener, so it seems better to keep it here.

If you update or replace an existing Wine installation, the first thing to do is to save your work. As always be sure to have some backups available.
You have to distinguish between the wine application, the wine software package and the .wine hidden filesystem. This hidden filesystem is not removed when you uninstall a wine software package, because that’s the place were your windows applications (Scrivener for example), user data, and the Gecko, Mono, .NET etc packages are stored.
To avoid any interference with previous wine installations, it is best to delete this hidden .wine filesystem as well. It will be recreated at the first use of the new wine system…
The same applies to PlayOnlinux, if you have deleted the application packages, you can also delete the PlayOnLinux related filesystems.

awesome. thanks! that all makes sense. trying to get windows scrivener working is my first foray into wine and dealing with virtual drives.
I backed up my files, deleted both ‘play on linux’ folders and everything else appears unaffected.

I have scrivener loaded and running under wine, and activated.
Thanks so much for the help!!

Trying to install on ubuntu 20.04 and winetricks won’t run when it is in /usr/local/bin
Moved it to /usr/bin and it does run now.

You shouldn’t have to move binaries around to make them work.

Do you have /usr/local/bin in your PATH?

Yeah, something is messed up with your path. /usr/local/bin should always be in it, because that’s where users are supposed to be able to install software that doesn’t mess with the system software.

Thanks for the help.
Sadly I’ve tried these steps multiple times in Ubuntu 20.04.2 LTS, including uninstalling and re-installing wine, winetricks, winbind, gecko, mono & Speech SDK, but when I try to install Scrivener I get this error:
“called Tcl_Close on channel with refCount >0”
Any suggestions on what to do here? It’s killing me…

It seems related to the Scrivener installer which is not optised for Linux, try the following :

  • launch winetricks in a terminal windows to get the error messages
  • if you get the ‘TCL_Close’ error, close your Linux session and retry

My iScivener nstallarion :

Ubuntu Mate 20.04.2 LTS
wine-5.0 (Ubuntu 5.0-3ubuntu1) → from the Ubuntu repositories
winbind → from the Ubuntu repositories
latest winetricks → from winehq.org
wine-gecko-2.47.2-x86-> from winehq.org
wine-gecko-2.47.2-x86_64-> from winehq.org
wine-mono-5.1.1-> from winehq.org
sapi (native) (Windows) → throuh winecfg setup
Scrivener-29920-installer_x64.exe → from literatureandlatte.com

Good Luck

Thanks for the speedy reply RoyalTyrell.
It took a fair bit more screwing around (as an almost complete novice) but I got there!
I removed then re-installed wine, winetricks, winbind, then had to manually add gecko before initializing wine (askubuntu.com/questions/1236811 … rt-in-wine).
I created a 32bit wineprefix (coz nothing else was working) and installed speechsdk via winetricks with your guidance.
Then I manually added Mono (dedoimedo.com/computers/win … -mono.html) before installing dotnet (also via winetricks)…
Closed winetricks and opened via terminal, to install scrivener via winetricks, 32bit prefix, uninstaller, install scrivener .exe
Now I have Scrivener working through my 32bit wineprefix, and have even been able to register (a problem I had last time before my free trial expired).
This probably sounds like a chaotic mash of novice actions, but I’m just so glad to be able to get back to my writing in Scrivener!
Is it an issue that I’m running with a 32bit prefix? Thanks for your help!

guess i’ll try again to see if I can get Wine 5.0 working then.

Yes, it is.

I’ve been trying to install speechsdk forever but it keeps saying the checksum fails, so won’t install using winetricks. I tried downloading it and installing via the wine uninstaller which appeared to work, but Scrivener 3 won’t get past the “loading spell check engine…” stage.

Finally used a workaround by setting sapi to native in winecfg. Scrivener works now! but no spell check tho, right? Now to recover my license…

FYI, if you’re getting issues with md5 checksum errors and winetricks, upgrade winetricks.