Omnioutliner: Not sure what I did.

While converting to Scrivener from a couple of different tools, I was importing a few omnioutliner files. I tried things like cut-n-paste and also export/import in a few different formats. On a whim, I just tried dragging an OO file into the Scrivener binder. Surprisingly, it worked. Sort of. I have a full view of the OO file in the binder, with disclosure triangles etc etc. So I have two questions:

  1. Is the file actually now embedded in Scrivener, or is this only some kind of link?
  2. I can’t edit the file at all. Is that because it’s a pointer to the original, or is there some other reason.
  3. I notice that it’s slow to open/close sections of the OO file within Scrivener.

Basically, I want to know if I’ve stumbled onto something that isn’t supported, and should instead go back to cut-n-paste.
Thank you!

If it created multiple entries (one for every item in the outline) in the binder, then the fact that you can’t edit it is very odd.

If there is only one entry, then you’ve just imported a copy of the outline file, and if you are able to manipulate it in some way, that suggests that you’ve opened it in a tool external to Scrivener (you can do that from within the Scrivener interface). You’d be able to tell if that’s happening pretty easily: while manipulating that window that contains the omni outline, does the menu bar read “Scrivener File Edit…” or “Omnioutliner …”?

It’s possible that what you’re viewing (if it’s still inside Scrivener) is the Mac OS quicklook view, which Scrivener leverages. Typically, this has just been a read-only snapshot of the contents of a file, but I suppose it could have gotten more sophisticated since I last used the feature, allowing you to expand and collapse some elements for viewing. It should work in the Finder if you look at the original and change the Finder view so you can preview the contents of files you click on, without opening their application.

EDIT: Looks like quicklook HAS gotten more sophisticated since I last bothered with it: … h14119/mac

I’m pretty sure that I’m seeing a quick-look preview of an imported copy of the file.

For future forum searchers: I’ve found that there isn’t a perfect way to import pieces of OO files into Scrivener, but the way that seems to preserve at least enough formatting to make the result reasonably readable is to export from OO to MSWord (indented) and then read the resulting file into Scrivener.

Have you tried exporting from Outliner to OPML? I haven’t used outliner for a long time but I think it can export OPML, which Scrivener can import.


I’ve never tried that. Until now.

The current version of Omni Outliner does export to OPML and it imports into Scrivener in semi usable form. I just created a simple file to try it and it imported just fine. I haven’t done more than just import it and look to see if I got what I started with. I did.

After playing with it more, the imported outline doesn’t modify like I think it should. I stopped using Omni Outliner because it’s hard to do anything with the outline after creating it, at least in Scrivener. Outlining in Scrivener works just fine.


Edits in bold.

Have you tried Dynalist? I’ve been using OmniOutliner for many years, but have recently started doing more and more work in Dynalist. It also exposrts to OPML that works well in Scrivener.