Opening a Scrivener file on another computer

I recently bought and downloaded Scrivener onto my new netbook (I already had the free trial on my laptop, where I had been working on a project). I want to open the project on my netbook, but when I send it to myself (via email/DropBox, etc.) and open the project, the text is missing. The chapter titles are there, but when I click on them their content is blank. I also tried making it a zip file and opening the project via DropBox, but I got a Location Access Error that said “File is not writable Access is denied. Auto-saves need write permissoion to your project.” Help? I really don’t want to have to copy and paste everything from one project to another, although I can if that’s the only solution.

No, you certainly don’t need to resort to copy and paste. It sounds like you might only be copying the .scrivx file? You’ll need to copy the entire .scriv folder containing the .scrivx file–zip it up first if you want to email it–as the .scrivx is just the file that pulls everything together and displays it in the binder; your actual text and other files are all stored as individual files within that .scriv folder.

It’s filename.scriv, so I think the format is correct, and it’s a zip file as well. Am I just not opening the right file within the folder? Do I have to open up multiple files?

If it is still inside the zip file, you’ll need to extract a copy out to the disk first. Just double-click on the .zip, and then drag the whole .scriv folder out to your documents or desktop and then try opening that folder and double-clicking on the .scrivx file.

Okay, now I’ve got it where most of them have text, but three of them have chapter titles but are completely blank. :frowning:

I’m trying to share a Scrivener (backup) zipped file from my Mac to a friend using Scrivener on Windows Vista and also get the “Location Access Error” when she tried to open the .scrivx file. See screenshot. I made sure that “Everyone” has “Read/Write” access on the Mac side. It shows “Password No” in the screenshot. What am I missing? Thanks much.

You need to extract that project from the Zip file first. If you look at the path of the project, you can see it is currently in a Temp folder inside your hidden AppData folder. This is what provides for you the illusion of being able to browse a Zip file as though it were a normal folder. It is however not a working area and will always be read-only. Scrivener needs full read/write access to open a project. So step back up to the top level of the .zip file and drag the whole “KCProject.scriv” folder to a working area on your desktop, then open it from there.

Oops! I’ll ask her to give that a try.

Took care of the access issues. Thanks. Now when she double-clicks on the KCProject.scrivx file, it goes to the “New Project” window. See screenshot. Same result if she uses the [Open Existing Project…] button and selects KCProject.scrivx.


Kind of sounds like maybe that’s all she copied? As noted above, the entire folder needs to be copied, not just the .scrivx file. That’s just a single text file that contains instructions on what the Binder should look like (and a few other things)—it does not contain any of that data. That is what the other folders are for.

We did have all the files from unzipping in that folder. However, she noticed in the .scrivx file properties a check box to “Unblock”, so she checked it and it loaded fine. Yea! :smiley: Perhaps this is a Vista security default to prevent a file from accessing other files?

Thanks again for all your help.

Hmm, interesting! That might be. I’ve never heard of such a thing happening before, but there are so many settings available for Windows that it could be an unusual one came into play here. Glad to hear it’s working now.

Well she spoke too soon. :frowning: She saw the Binder come up and thought it was okay. Only later did she go further and found, as you indicated above, that the binder items were empty. When she tries to change the various other files’ permission to Write, it changes back, when she looks at it again. I suggested her Vista user privileges might need to be changed to give her that capability. I passed along one Vista user’s (not a Scrivener user) steps to do that. She’s getting ready to leave town today, so I may not find out the results for a few days.

It seems others would have already uncovered this problem. From this thread, others are exchanging Scrivener files between Mac and Windows. Maybe it’s a Vista only problem?
General questions:

  1. Is there anything special a Mac Scrivener user needs to do before zipping (using Scrivener Backup) and sending to another user? Assuming the Scrivener file isn’t locked, etc. We’ve used email & USB drive thus far. Another thread discusses the Dropbox uniqueness.
  2. It appears a Windows user (Vista only?) needs to: “Unblock” the .scrivx file in order to allow it to access other files, and to set User privileges to allow the user to set the other files’ Properties/Advanced to “Write” permission.

Any thoughts appreciated. I’ll post our results and final resolution here.

I’m not aware of anything special that needs to be done. If the Mac user right-clicks on the project in the Finder and chooses to compress it, then that will cause a “__MACOSX” folder which is annoying, but can be ignored/discarded without any side effects. In fact, zipping a file and then unzipping it is an easy way to clear permission problems on a Mac because the default zip settings it uses do not retain permissions. It’s an easy way to move a .scriv project to a different account on a Mac, for instance.

Secondly, this isn’t a widely reported issue. In fact it’s the first I’ve heard of it, but I don’t want to say that it never happens because I typically just handle the Mac side of things and lack a breadth of knowledge on the matter of Vista.

So I would suspect the settings on this particular Vista machine, rather than anything common like Zip, Vista, or Mac. “Blocked” is terminology I’m not familiar with. I don’t think that’s coming from the zip archive or the Mac.