Outline view issue

Been using Scrivener for more than 10 years, and I always just had a collection of documents for the the chapters in my Manuscript folder. This time I have imported an outline from Plottr, and the Documents (along with synopsis) for each chapter is buried inside a Chapter folder which is buried inside an Act folder.

It appears that there is no exploded view of this. If I want to see my outline, I have to go through and click to open every folder. This makes no sense.

What am I missing?

First off: there is a command to expand all.
View / Outline / Expand all
Just make sure the focus is where it should, before using the command. – Binder or outliner.
(Else, it’ll just be greyed out.)

As for the unnecessary hierarchy, this I don’t really know, but I’d personally first investigate on the Plotter side of things. (Scrivener usually does with what it gets ; it doesn’t make up extra folders for no good reason.)

This said, if you have no intention of going back and forth between the two apps, it should be easy to fix without leaving Scrivener, once you’ve expanded all, via drag and drop in the binder. (Get rid of the useless levels of hierarchy. → Pull the real content out of there, and delete whatever is the pointless extra.)

Sorry, I didn’t explain what I wanted correctly. I want to be able to see an actual outline that includes the chapter title and the synopsis in outline view without having to go through and expand each chapter folder. The command you cited above does expand the view in the binder, but I cannot get it to do it in the outline view.
I just pulled up one of my old Scrivener files, and I found I was able to get it to do this before, I just don’t know how I did it.

If you are blocked at a stage where it is not that you can’t expand all in the outliner, but rather that you can’t see the whole at once, that (very likely) means that whatever you imported IS NOT in your draft/manuscript folder in the binder.
You probably have it almost where it should be, but outside of it.

Could you screenshot your binder with the draft/manuscript master folder visible?

Else : I can’t think of why the outliner wouldn’t expand. (Make sure it has focus - click any element in it - before launching the expand menu command.)

Have you tried Control/Command-clicking the folders to expose the “Stacked folders” view?

In the screenshot you’ve so far provided, the synopsis IS in the chapter folder. Not somewhere in a file inside it.
Perhaps that’s what you’ve got different.
Otherwise, to display the synopsis in the outliner, it is in the list, arrow pointing to the right, at the very top, right side. → …with synopsis

1 Like

…or the icon at the far right in the footer bar. :wink:

1 Like

The View ▸ Outline ▸ commands will work in whichever outline view is focussed, so if you have focus in the binder, Expand All would expand the hierarchy there. To expand in the outliner in the editor, just click into the editor first to give it focus, then use Expand All.

For fully expanding sections, you can also Alt+Click on the disclosure arrow to the left of the document icon, or use the Alt+RightArrow shortcut. That latter can be used on a multiple selection, so another option to expand all in this case is to use Ctrl+A to select everything in the outliner, then Alt+RightArrow to fully expand each of the folders.

1 Like

Thanks to all who have tried to help me. The last comment about clicking inside the outline as opposed to clicking on the heading above the outline worked to expand the contents with the synopsis for each chapter showing.
It’s still not the method where I had used back in that older book written in 2018, but I had just taken one of Gwen Hernandez’s Scrivener classes, and it must have been some trick she showed in the class. I’ll go back through my notes to see if I can find it as I really like that way of viewing the folder titles and the contents of the synopsis.

I’ll include a screenshot of what it looks like now with the imported info from Plottr.

Your very first screenshot.

The synopsis is in the synopsis panel of the chapter’s parent folder ( → as an element in the binder). As any element, file, folder, file group, can all have their own synopsis in the dedicated panel.

Where here (in this new screenshot), the synopsis is rather attached to a file inside it.
That’s why you can’t see it without expanding the chapter’s parent folder.

Take the synopsis text from your scene and paste it into your chapter’s parent folder’s synopsis panel and you’ll get what you want.

It clearly can be seen that in your current case, the synopsis is in a file inside the parent folder. Not in the binder element that this parent folder is.
The icons even tell you so:
image VS image

In other words: something you did in Plottr ended up creating a hierarchy level you didn’t actually want/need.
All you have to do now, is to either move things where they belong and delete the useless files,
or, in case your parent folders are just empty dummies and the scenes inside them is what you whished would be top level, pull those scenes out of their useless dummy parent folder and then trash these unneeded folders, making your scenes as they currently are your new top level files. ← The later probably your case, seeing how none of the files visible in your second screenshot actually have a body text, and consist solely of a title + synopsis. (I know this because of the icon. Should you have a body text in those files, the icon would be of a paper sheet, not of a cue card.)

. . . . . . . .
For some reason your import from Plottr has all of your files (or seems to, from those I can see) excluded from compile.
You should fix that too, as otherwise you won’t be able to use session targets, and most of what is wordcount related.
(You’ll have to do it at some point, assuming you’ll eventually want to compile :wink: , so might as well do it now before it causes you other issues…)

1 Like

Thanks for that great explanation. I understand!

At this point, all I have is the outline. I haven’t started writing the chapters, and I was just starting to set up my columns there for the things I care about, including POV, word count per chapter, and include in compile. (I used to have a carefully crafted Scrivener template using elements of many others’ templates for my novels, but somehow I’ve lost it, so I’m also trying to work out a new “My fiction” template along the way).

I was trying Plottr out to outline this new novel, but I only tried it based on the promise from the Plottr folks that once plotted, the outline could be ported over to Scrivener. I’ve already spent hours trying to make that happen.

To be honest, I’m not sure I will do it again. I’ve used Aeon Timeline for the last 4 novels, but never tired to import it into Scrivener. It is easy to use it outside and alongside Scrivener. But the plot and characters need to be imported, and so far this has been very kludgy. I still have not been able to import the character profiles due to a weird issue where I created my characters attached to the series, but not to this particular novel. There’s no work around forthcoming.

Anyway, I know what I have to do to get my chapters to display the way I like. Thanks again.

1 Like

I did try Plottr myself a while back (years ago). And, not that I had issues of any kind (I didn’t play around with it long enough, perhaps), I quickly understood that I had no use whatsoever for it.
Nothing it offers/does that I can’t easily get/do in Scrivener.

Ah, I’d missed the real issue in my inept reading earlier, but it is possible to clean up the imported outline to better match the structure of your older project, if that’s something you’re still after. Essentially, if I understand correctly, what you want is to remove all the “Chapter” folders and have the documents with title and synopsis directly within the Manuscript folder, yes? So replace this:

   Chapter 1
      I Aboard the Trequesta
   Chapter 2
      II Pearl Harbor

with this:

    I Aboard the Trequesta
    II Pearl Harbor

Here’s a way to do that:

(Preliminary step 0: File ▸ Back Up ▸ Back Up To... to make a backup of the project before you move a bunch of stuff around, just to be safe!)

  1. Ctrl+Shift+F to open Project Search at the top of the binder
  2. Click the magnifying glass on the left to set the search options to Title, RegEx, Search Manuscript Only, Search ‘Included Documents’, Search ‘Excluded Documents’
  3. Search for ^(?!chapter).*$
    With the above limitation, this will return all items in the Manuscript folder with titles not beginning with “chapter”; in other words, going by the screenshot, it should return everything except those folders you want to get rid of. (If you have a document with an intended title beginning “Chapter” it would be excluded, but I think you’re safe since the pattern seems to use Roman numerals to begin the text, so “III Chapter” would still be returned.)
  4. Click into the results list and use Ctrl+A to select everything
  5. Right-click on the selection and choose Move To ▸ Manuscript
  6. Click the X in the Search Results header to close the collection of results and return to the main binder view
    Now you have all the actual chapter documents outside of those “Chapter” folders, still in the proper order and at the correct level within the Manuscript folder. So all that’s left is to clean up:
  7. In the binder, Shift-click to select all the now-empty chapter folders in the Manuscript and Ctrl+Delete to move them to the Trash.

It looks long but it’s pretty quickly done. And although it’s rearranging, nothing is actually deleted, so if you accidentally put something in the Trash you could drag it out again. The main thing would be if the search in step 3 didn’t return exactly what you wanted; you could tweak the search, or you could just do a little extra clean-up before step 7 to move any files that didn’t get caught (the theoretical intentional item titled “Chapter”.)

1 Like

We all “did”.
It only became known (as a part 2) once the OP had successfully expanded the outline.

Ah well, it was a long day/week; I wouldn’t put it past me to have overlooked the key comment! :grinning: