Page break not compiling in one place only

I’m compiling my novel to have three separate pages before the first chapter: Title Page, Dedication, and Part One.

They are all under the Title Page folder and all are selected to have a page break before. Yet no matter what I do, I cannot get a page break before the Part One page. The only thing that worked was giving the Part One it’s own folder, which done NOT work because in the kindle version links the Part One as the first chapter, messing up the links to each of the chapters.

This is the ONLY place in the entire project where the Page Break does not work. I even tried removing the Dedication page and combining it with the Title Page, but the Part One still wouldn’t leave a page break.

Is there something else I can do to get the effect that I want? I cannot understand why I can’t get a page break, especially since it’s selected! I’ve even tried unselecting and reselecting it. Nothing works.

Thank you.

I can’t think of any reason straight off why ticking page break before would not put a page break before the document as it should. From your description, your binder looks something like:


  • Title Page (folder)
    • Title Page (document)
    • Dedication (document)
    • Part One (document)
  • Chapter (folder)
    • scene (document)

Is that right? I made up the last bit based on your mention of folders and chapter numbering. Aside from the “page break before” for each of the documents within the Title Page folder, what other settings do you have for the compile contents and formatting? Are any of these set to compile as-is, or are any not selected to be included in compile? In the Formatting tab, what elements to you have selected in the table at the top? (A screenshot would be fine if that’s easier.) Also, what are the dividers set to in the Separators tab of compile?

I’m assuming that each of the documents in the Title Page folder contains text that is compiling; is that true? Where’s the next page break after the “Part One” document? What format are you compiling to and what program are you using to open the compiled file?

Sorry, it’s a heap of questions, I know, but something in there might raise a flag.

Thank you for your time. I’ve answered most of your questions with screenshots. Although I can’t get one of the formatting tab, every time I open the tool, the tab closes. The only thing checked in that tab is “Show Ruler”. There’s nothing selected from the tables.

Thanks again.

The Formatting tab I meant was the one in Compile; sorry for the confusion. Going by what you have there, that shouldn’t necessarily matter though because you’ve marked those top three documents to compile as-is, which means they’ll override whatever elements are set for inclusion since as-is documents always compile only their text.

I did try playing around with this and compiling to a few formats, including .mobi, just based on what I could see in your screenshots, but I haven’t been able to reproduce the problem. Just to be clear, though, we’re talking about a page break before the text of the “Part 1” document, not after it, right? Because I can see with your settings how you would get only a single return between the text of “Part 1” and the text of your “Ch1” document, so that would be much easier to explain and fix. :wink:

And to double-check, you’re compiling to the .mobi format and viewing the file in Kindle Previewer? Does it look the same in all the different device options, or is it specific to a certain one?

Correct, the page break is missing in between the Dedication and Part 1 pages.

It’s happening in all formats that I’ve tried. (PDF, Preview, etc.) Although now the mobi version appears to be working as far as the page spacing goes. But when I click the links in the table of contents, they go to the wrong location. Although it keeps changing which wrong location, so maybe that’s a kindle issue. (I’m checking it on my kindle fire, not the previewer.)

I’ve attached a screenshot of the formatting section in compile.