Page breaks... well aren't when compiling to RTFD

So, I’ve got my first document ready to distill out of Scrivener now.

It’s a 33,000 word technical document with a lot of drawings in it weighing in at around 400 A4 pages at the moment.

I’m now making sense of a lot of Scrivener’s features which until the point I came to structure the document for distilling didn’t mean an awful lot to me. Cool things like compile as is have proved great allowing me to override any fonts that got pasted into the body text whilst controlling certain source code files more closely and ensuring that the source is rendered in Courier for readability. Love it :slight_smile:

However, I have noticed one problem. I can render to PDF just fine and Page Breaks come out just where I expect them based on the rules set to break when a folder occurs after a text so I’m sure that bits working fine… when I render to RTFD however and load it into Pages I don’t get any page breaks at all!

What I actually see immediately prior to the Title (which I’m getting from the node titles rather than having them embedded in my text) is a peculiar whitespace. It’s almost as if the RTFD format being generated has the wrong Page Break sequence embedded and Pages doesn’t understand it.

Any ideas?

Cheers,

Andy

Oh wait, it appears to be Pages that is causing the problem.

Export a file to RTF created in Pages with a Page Break in there and then open it in Pages and you get a blank in front of the text instead of a page break >_>

Hi,

Yes, unfortunately this is down to Pages’ limited RTF and RTFD support - it drops any page breaks in these formats. Unfortunately going to Pages is probably the most difficult of all the word processors, because:

A) The .pages file format is private so we can’t support it directly.

B) Pages has very poor support for RTF.

C) Scrivener’s support of native .doc and .docx is basic (using just the standard Apple exporters), because we don’t have the resources to write our own converters at this stage.

The workaround is to export to RTF and open the RTF in Word or OpenOffice, then save from there as .doc and open that in Pages. Also, be sure to leave feedback for the iWork team, asking them for better RTF support:

apple.com/feedback/pages.html

All the best,
Keith

Oh I did already :slight_smile:

Of course the workaround won’t work for me because I have images that I want to preserve and OpenOffice, LibreOffice and Abiword don’t support RTFD… I know I’ve tried them all.

I guess I’ll put a dummy tag in and put the page breaks in manually searching from Pages.

Oh no, I see Scrivener actually will dump the graphics into RTF files not just RTFD… it’s just pages doesn’t attempt them in RTF files.

Now the only thing is the images come through without the file information. I assume that this is because it isn’t stored as a Picture Clipping any more…?

Right, you need to go from RTF to DOC to get the best result with Pages, using one of these other word processors. Pages reads .doc/x files pretty well, so as long as you have a good way of converting an RTF to DOC you should be fine.

Right, I found a clean way of doing this. I made a custom separator…


Compile, open the document in Pages and turn on ‘Show Invisibles’, create a Page Break…

Then I select it like any regular character and Cmd-X to Cut it like any regular character and finally paste it into the Find Replace field :slight_smile:
PageBreak4.png

It may be a little kludgy but it works a treat and saves manually visiting all those pages ^^

which of course works in most cases but it mucks up the convenience of being able to mark through the inspector that you want a page break before a section since the rest of the compilation will just generate a page break.

OK, here’s the solution for Pages users… it’s pretty ugly but it works.

Firstly make sure that you don’t have the text ‘\page’ stated anywhere in your Scrivener document. If you do then change it globally and change it all back after the exercise.

Export the Scrivener document using regular page breaks to RTFD.

Create a Backup copy of the RTFD in case it mucks up.

Right click the RTFD and show package contents.

Find the file called TXT.rtf and open it in a PLAIN text editor, Neither Pages or TextEdit will do it… even if you rename it to TXT.TXT both will recognise it as RTF. I use TextMate for this.

Do a search and replace replacing ‘\page’ with ‘\par <[pagebreak]/>’ strictly speaking this starts a new paragraph but a page break does that anyway.
pb1.png

Now save the file and open the main RTFD in Pages.

Create a real page break, turn on show invisibles, select the page break (it’s a little page icon) and Cmd-X it to cut it.

Hit Cmd-F and paste it into the replace field putting ‘<[pagebreak]/>’ into the find field.
pb2.png

Hit replace all and you should have all your page breaks in the right place including ones generated by using ‘Page break before’ flag on your Scrivener notes.

Now double check your document.

Thanks, Andy! You forgot the last step though.

  • Contact the Apple iWork team and lodge a complaint about Pages’ lack of RTF support.

:slight_smile:

Already did that, and duplicated the post (making it more generic) over at discussions.apple.com.

It’s Andy btw :slight_smile: I Am A Smith ^^

Ah, sorry, mixed up user names in my head! :blush:

No worries, I usually get folks calling me Ian because of my handle :unamused:

Heh, I think Ioa can relate to that one.

Nah! Nobody every calls me Kyle. Nevuh.

Well, just to let you know that Scrivener became today the sole reason that I put Microsoft Office on my Mac. I was dubious of ever getting it off properly if I wanted to but found a nice and easy to follow 10 step exercise (should I say 10 step programme?) to completely remove it if I want to and I also found that with Word, Excel and Powerpoint only installed it’s all toned down so I’m not too unhappy about it.

But yes, if I wasn’t so hooked on Scrivener now M$ wouldn’t have gotten that sale :unamused: