Page setup in docx compile doesn't stick in M1 Mac

I have exported this file repeatedly on my Mac Book Air in the 6x9" page size. I just opened the Scrivener file in version 3.2.3 on a new Mac Mini M1 chip and compiled, but the page size keeps reverting to A4. Is this a known bug?

Thanks very much!

It is not a known bug. My M1 Mac handles page size changes just fine.

How did you transfer the project to the M1 Mac?

Have you actually edited the page size setting on the M1 Mac, or is the problem that it didn’t “remember” the setting from the MBA?

Are you attempting to change the Editor page size, or the page size setting in the Compile Format? If the latter, are you using one of the Formats supplied with Scrivener, or did you create your own?

Hi, kewms,
Thanks for your reply! I transfered the Documents file including all my Scrivener projects with the Migration App and an ethernet cable. I changed the page size setting in the Compile Format, but it doesn’t stay, even after I save it to the format. I modified a print format from Scrivener to create a 6"x9" size. (Now that I type that, I can’t remember if Scrivener had that page size as a default option and I only changed other formatting. I modify the format for every book in my current series to allow for different scene separators etc., but the page size has been the same for all but one book.) The format worked on my MacBook Air this afternoon with Scrivener 3.2.2. and generated the correct page size this afternoon. I gave up on the Mac Mini with Scrivener 3.2.3 for today’s deadline, but I’d still like to make it work.

Please install Scrivener 3.2.3 on the MBA and see how it behaves. That is, is the issue with the version of Scrivener, or with the hardware?

Thanks for your suggestion! Is there any way to roll back the version on the Mac Mini to 3.2.2? I understand the logic, but I don’t really want to break the one that is working. I’m in the middle of releasing a new book.

I deleted Scrivener 3.2.3 from the Mac Mini and downloaded Scrivener 3.2.2. When I opened my Scrivener file again, it had lost the page setup again. I checked the same Scrivener file afterwards on the laptop (synched via iCloud) and that one–3.2.2. on MacBook Air–kept the page setup.

Don’t know if that helps.

I was a little puzzled that the Mac Mini didn’t ask me for my Scrivener license again, so maybe I didn’t delete the software cleanly. I just tossed the in the trash and opened the earlier version.

The license information is stored separately from the application itself, and is actually fairly hard to remove.

It’s possible to install Scrivener 3.2.3 and 3.2.2 side by side on the same system. Just change the names in Finder so you can tell which is which.

There are known compatibility issues with Scrivener 3.2.2 and the latest version of Mac OS, so I would not recommend downgrading your Mac Mini copy.

To change the page size for a Compile format, do the following:

  • Open up the main Compile screen with the File → Compile command. Right-click on the format you would like to edit and choose the Edit (or Duplicate and Edit) command.

  • Go to the Page Settings tab.

  • Uncheck the “use project page settings” and “use default paper size” boxes.

  • Click the “Page Setup” button to choose the paper size you want, “Margins” to define the margins.

  • Click the “Save” button in the bottom right to save the revised format.

When I do that, the new page size is correctly saved and is there if I re-open the format. If that’s not what you’re seeing, exactly where does it go wrong? If you Compile immediately, do you get the correct result?

Exactly where did you store the revised Compile format? If it is a “Project Format” it will be synchronized to other computers along with the project, but “My Formats” are local to the current system.

When I followed those steps, it looked like Scrivener saved the page setup in that window, but when I compiled immediately, and the file opened automatically in LibreOffice, the page size was wrong. Then when I went back into Scrivener to check the page setup, it was incorrect again

Hmm. What happens if you compile to another format, like PDF?

I didn’t try PDF. I tried .odt and .rtf without success the other day and didn’t try .doc because Scrivener recommended Java for that. Since I need a print quality PDF, I can’t generate that from a regular PDF in LibreOffice.

I understand. I’m asking for troubleshooting purposes.