Papers 3 citations working in Scrivener 3?


Excited to see the new Scrivener being available! However, before I upgrade, I’d like to know if Papers 3’s citation functionality works in Scrivener 3. I have a few text editors where citations does not let me insert a citekey, I just want to make sure Scrivener 3 will not be one of them. Can anyone confirm this is working?

Many thanks in advance.

Papers 3 citations does not appear to function in Scrivener 3.
This is a regression from the previous version.

Ah, bummer. Thanks for reporting - this is good to know.


L&L: when do you plan to support Papers 3 ( on Scrivener 3? Or, if it’s already done, how to set it up?
That’s very important for my writings…

Many thanks for the answer,


I’m a Bookends user, rather than a Papers3 user. However:

  • Have you checked in Preferences > General > Citations that Papers3 is designated as your citation manager.
  • Scrivener 3 works no differently from Scrivener 2 in respect of using citation codes rather than Cite-as-you-write, and Cmd-Y is still the shortcut in both directions.
  • I’m pretty sure that at least one of the beta-testers is a Papers3 user, and I don’t remember any posts during the lengthy beta-testing period saying there was a problem with Papers3, but my memory may be at fault.

Perhaps @matsgz—who strongly supports Papers3, if memory serves—will come along to help.


I contacted Papers Support yesterday asking if there was something wrong on their end (as far as I can see, they are the ones who build the support into Magic Citations to insert citekeys into other apps), and received a less than helpful response that they will fix this in their new version.

Unfortunately their new version will be a paid, recurring subscription product [*] which is really just an unfair proposition for people who don’t want to rent a bibliography manager.


Magic citation and Scrivener 2 work together perfectly. I also contacted Papers yesterday and pretty much got the same response. Can I ask what other reference manager software works together with Scrivener 3, in the way that Papers does with Scrivener 2 (i.e., magic citation, not Cmd-Y way)? TIA

From what I understand, the new version of Papers/Readcube will not have magic citations at all and will only work with Word. I had hoped I could finish my thesis in the new Scrivener and the old Papers, but I’ll wait with updating Scrivener until I have found a new reference manager.

It really is disappointing to see Papers all but abandoned since the ReadCube merger. With the lack of updates and no communication from the company, it seems the writing is on the wall for Papers.

I’m now another one looking for a new reference manager with similar citation support to Papers3/Scrivener 2 – any suggestions?

The problem is likely with Papers. I had the same problem with Ulysses when they went through their last upgrade. It seems Magic Citations is so complex, it needs specific information from every app it works with. Upgrades break this connection. In the past the makers of Papers would issue updates so that their app would be still usable. Not the new owners. My guess they will cripple Papers so that people move to their own ReadCube app, which only works with MS Word.
I jumped over to Bookends, which has improved a lot since I last used it in 2013. BTW, another good alternative, Sente, seems to be closing down.

The latest version of bookends has improved its support for importing databases from Papers 3. And for those who want a magic citation interface (I’ve never used it so YMMV), if you use Alfred I curated a set of tools, one of which does a live author search from your database and pastes the citation:

That’s awesome. Will try it out right away. Thanks!

This is an issue with Papers3. You can actually make it work (temporarily) with simply adding one line that includes the new app-ID of Scrivener3 into:

There, you have:


Simply adding:

will enable it again, but Papers3 will not restart due to this modification being detected…

Sucks really.

Is there any way to make Scrivener report a fake app-ID?

Have you tried to re-codesign the app after the modification?

sudo codesign -f -s /Applications/

Oh wow, that would be cool! However, I do get:

And I still get the error message at Papers3 startup:

I’m no expert in these things but I think Papers actually checks itself against some specific sha hash or something?!?

Ah, this is great. I was looking at doing exactly that (modifying the plist file) this morning - it lasts while Papers is frozen and waiting to be quit. It does indeed seem to be an internal check by Papers - I have already emailed them that adding ‘support’ for Scrivener 3 would only be a matter of adding a single line of code. Perhaps some more emails their way puts some pressure on the case.

Alternatively, the Alfred workflow seems interesting. Thanks for sharing that!

I have just been told that Papers 3 will see an update ‘in the next week or so’. Fingers crossed this will sort us out.

I heard that before! There are a few bugs in annotating and highlighting in Papers that should also be fixed by the long awaited update.

A new version has been released (3.4.12) but the problem persist.

I was so happy to see the update, anticipating it would resolve the issue. But alas. I also noticed it was built on 22 November, so not much could have been done I suppose. It would help if everyone that would like this resolved posts at their forum: and email their helpdesk. It is being read, although you may not get a response.