Paragraph indent not working

I say not working but more likely I haven’t got it working! In Formatting Preferences I have the indent set to 0.5in but in a new document, after hitting the return key I just get a new line with no indent. Is there something else I need to do to get new paragraphs to automatically indent?



When you say ‘in Formatting preferences’, where do you mean?

There is basically a hierarchy of how most formatting preferences are set for new documents.

First of all, look at Project > Text Preferences. If the ‘Use different default formatting for new documents in this project’ option is checked, then this takes precedence and it will override the settings in Preferences > Formatting.

So, if you’ve got the indent set in ‘Project > Text Preferences’ (with the option above checked), it doesn’t matter what you do in 'Preferences > Formatting, it will always override the general preference setting in this project (only).

Of course, this is a separate issue from any changes you make in any existing document. Basic paragraph formatting changes are not inherited by new documents, only from either of the two preferences I’ve outlined above.

Project -> Text Preferences doesn’t have that checked. The text area in that screen is greyed out and shows the indent settings from Preferences -> Formatting. In Preferences -> Formatting I’ve dragged the second horizontal slider to the right by 0.5in. I presume that’s the paragraph indent one as the paragraph gets indented in the text area when I do that.

Have you been testing in a fresh new document, or the same one all along? This setting only sets up how new documents are formatted. To update existing documents, use the Documents/Convert/Convert Formatting to Default Text Style menu command.

I’ve been adding a new document each time. Screenshot attached. OK it’s not attached. I’ve uploaded it twice and it doesn’t attach

Try this…

  1. Create a new document and write a single paragraph in it – just one. Format that paragraph exactly the way you want it: indents, line spacing, font etc, etc. The content doesn’t matter, you’re only after the paragraph settings.

Don’t use the ruler to format the paragraph, use the more detailed tools available on the Format > Text menu (in this case Format > Text > Tabs & Indents…).

  1. Once you’re happy with the basic paragraph, make sure your cursor remains in that document, then go to Preferences > Formatting and press the ‘Use formatting in Current Editor’ button. The dummy text should reflect your format.

  1. Make sure Project > Text Preferences has the 'Use different default formatting for new documents create in this project is UNCHECKED.

Screen Shot 2016-12-10 at 11.25.33.png

  1. Select cmd-N for new document.

You should have an document ‘Untitled’ created: rename it and go to the editor. When you start typing it should use your new default paragraph style.

This works for me every time, so if you’ve followed these steps exactly and there’s still a problem, I’m not sure what’s going on. Sorry…

Fantastic, thank you! All working now. Your screenshots are much appreciated.

Glad it helped!

Just an extra point: your formatting now will apply for every new document in every new project from now on. If you want something different for just one project, then obviously, that’s when you use the Project > Text Preferences… dialogue with that box ticked…