Paragraph indent persists after numbering set to None

When I apply numbering to a paragraph, the paragraph gets left-indented. When I remove the numbering by choosing “None” from the numbering menu, the left-indent persists, and there does not seem to be a way to undo it.

P.S. By way of feature requests, I would also like to see an inline numbering option (that does not indent the whole paragraph) and I would like to see more number formatting options, for example (1), (2), and ordinals such as First, Second, etc.

At the moment, you can adjust indents by dragging the triangle sliders on the ruler (Format > Show Ruler) or using the keyboard shortcuts Ctrl+T/Shift+Ctrl+T for first line indent/outdent and Ctrl+Q/Shift+Ctrl+Q for left indent/outdent.

Thank you for that info.
– Martin