Paragraph Indenting

OK, now what’s happening?

In Scrivener 2, when I entered the combination of ctrl+option+command+right arrow (cursor) keys, it would indent the entire next paragraph. There was no overhang or no indented first line, it just indented EVERYTHING that followed.

I just tried that for the first time in Scrivener 3 and rather than indenting the entire paragraph, all it did was indent the first line of the paragraph, per the attached screen shot.

I NEVER indent first the first line of a paragraph.

I spent 10 minutes poking around in preferences but alas cannot find the setting in S3.

Please tell me what setting to revise so that I can return to indenting entire paragraphs with no first line indent.


Screen Shot 2017-11-27 at 8.16.38 AM.png

Increase Indents (for the whole paragraph) doesn’t have a default key combination assigned to it. You can set your own, of course:

I don’t know why but the key binding was changed:

You can easily change it back using System Preferences… :arrow_forward:︎ Keyboard :arrow_forward:︎ Shortcuts :arrow_forward:︎ App shortcuts … rtcut-mac/

Ok, this is now officially f’d up…

Easily? For who?

Am I understanding all this correctly? Iinstead of having a familiar set of keystrokes at my command, I have to create a customer keyboard shortcut bu typing the EXACT sequence of menu commands the “Menu Title” field? That is not “easily,” That is a PITA.

Or, alternatively, every time I want to indent an entire paragraph without a first-line indent, rather than the simple keystrokes I’ve been using for the past however many years, I have to go manually into the format>paragraph menu and go through three or four different commands?

Somebody at L&L please acquaint me with the thinking here. All I can see is that they’ve fixed an important tool that was not broken.

Sorry, this is starting to piss me off.


Not the sequence, just the menu item. Takes about 10–20 seconds to set up.

Ah. THAT detail makes a BIG difference. Was unclear in the earlier posts AND in the Keyboard Preferences instructions.

But now that I’ve made sense of it, I’m also seeing the previous missing logic in making this an app-specific custom configuration.

Instead of the 3modifies+arrow combo, I set mine up the same as the default setting for the OS: Command+[ -or- ] to increase or decrease the indents. Now I have the same keyboard combo for indents regardless of the app I’m using. So one less thing to remember.

That DOES make sense.

Thank you for the tip,. and for tolerating my outbreak of temper there.


Good to hear you have got things working as you want. Completely understand how frustrations build. I empathise more than tolerate. :wink:

You’re a gentleman and a scholar (except…wait… I have no idea what gender “Bridey” is…)


Certainly neither a gentleman nor a scholar. Just a writer.

Actually cmd-[ and ] are the system commands for go back / forward in history: web pages in Safari and Folders in Finder — so they’re bound by default to Back / Forward in Document history in Scrivener. These are some of more useful bindings in Scrivener for flicking through what you’ve been writing, irrespective of the documents’ physical position in the Binder, so it may be worth finding alternatives bindings for the indent.

Which programs bind them to indent?

(That’s assuming you’re on a UK / US keyboard of course — it may be different on others, in which case just ignore me…)

The reason this was changed is that Increase Indents/Decrease Indents are now just duplicates of the Edit > Move > Move Left/Move Right commands, but placed in the Indents menu for convenience.

So, to indent or dedent an entire paragraph you now just hit Ctrl-Cmd-Left or Right. And Ctrl-Cmd-Up or Down will move the paragraph up and down. These are the exact same commands as are used for moving documents left, right, up and down. Unfortunately there’s no good way of showing the same shortcuts in two different menus, though, which is why they don’t show up in the Indents menu.

Here is the answer!

Dammit I’ve had to search for this several times while getting used to working in scrivener, and once I find it again I’m able to work.

Makes sense. You know what would make even more sense?

  1. Selecting several lines and hitting tab actually indents all. (If you want to delete a selection, select and delete!) That’s how we are all used to doing it on all other word processing platforms.
    (In Word and I think Google Docs, you don’t even have to select the whole paragraph… tab the first line, drop to the beginning of second line, hit tab again and it assumes you are tabbing the whole paragraph.)
    2 ) maybe even add at least the option of some toolbar buttons for these commands, like in Word.

Thanks! I’ve made a note now that I’ve found the answer again, but would love to see this update.