Paragraph indents

I’m looking for some advice on a quick way to get the right format for paragraph indents.

My understanding of the correct way to show new paragraphs in a printed fiction book is this: a single return between paras; indent the next para; BUT the first paragraph of a chapter, or following a scene break is not indented.

This seems to be the accepted way of doing things, and how most novels are laid out.

I currently have all my paras indented, using the ruler. Easy. But how do I go about not-indenting the first para after scene and chapter breaks? (By scene break, I mean leaving an extra blank space)?

If I was using a word processor like Word, I’d probably set up a style and then go through and do it manually. At least it would avoid having to mess with the ruler time and time again.

So what about in Scrivener? I want to use the compile feature, and to make sure I can the book looking as professional as possible. Is there an easy way to do this?

Many thanks for any help anyone can offer.

Hi Simon,

In Scrivener, you are right that the way to do this is via Compile. In the “Formatting” pane of Compile, click on “Options”, and there you will find some ways of doing this:

Which option you choose will depend on how you have things structured. If you have each scene in a separate document and you want each new scene to have no first paragraph indent, then you would most likely choose “At the start of each new document”.

All the best,

Many thanks for the swift response - and sorry to waste your time. I really should have been able to find that option on my own, but for some reason I’ve never noticed it. It’s ideal. Scrivener really does have everything covered, doesn’t it!

You didn’t waste my time at all! Please feel free to fire away with any questions you have. Compile has a lot of options - necessarily, in order to cater for the flexibility Scrivener allows in the structure of projects - so it can seem a little overwhelming at first.

All the best,

Captain, is it safe to assuming this offer is not open to all members of the crew? I suspect that some of the … less singular individuals might be advised to limit the nature of “any” to a smaller subset of “relevant” questions.


I concur wholeheartedly with the sentiments expressed by the above :unamused: poster.

I did have a problem getting this to work for me - though through no fault of Scrivener. I had applied a couple of line returns and asterisks to separate my scene breaks, and put this at the top of each new scene document. That meant only the blank line was being recognised as the non-indented para.

For future reference, anyone trying anything similar might want to put line breaks at the end of the first scene, not the start of the second.

I got around this using the ‘apply formatting preset’ function, creating a new preset for a non-indented para, and then creating a keyboard shortcut for it. That still required some manual work, but not too much.

Out of interest, why are you insert asterisks and line breaks at all, rather than have Compile insert these for you via the “Separators” setting in Compile?

All the best,

Dunno… just general inexperience I guess. Or stupidity, maybe.

Eek, I wasn’t trying to suggest anything like that!

But if you do have scenes in separate documents, then it makes more sense to add the asterisks using the “Custom” setting for the separator between text documents in the “Separators” pane of Compile. That way you don’t have the separators littering your text, and you can compile to different formats with different separators should the need arise.

All the best,

Actually … how do you insert a double line break using the separators function in compile? Using ‘custom’, clearly. I can insert the asterisks that way, but if I try to insert a line break or para return, Scrivener interprets this as pressing the highlighted ‘compile’ button, and starts the compile process. Is there an instruction that can be entered to force a line break without this happening?

You can hold down the Option key to insert control characters such as return, but if you just want a double line break then select “Empty line” instead of “Custom”.

All the best,

Further to your advice about indenting of the first line of first paras in Scrivener, I have what appears to be the latest version of Scrivener yet when I call up ‘Options’ for Formatting in Compile I just have two options - ‘Insert subtitles between text elements’ and ‘Place notes after main text’. There is no third option as highlighted in red in the post from KB.

Is it me?

It sounds as though you are exporting to plain text, which obviously can’t support indents which is a rich text feature. What format are you compiling to?

Hi there. I’m still at the learning stage and I compiled and exported some sections to PDF using the Novel Standard manuscript format. (It’s Scrivener by the way.) Obviously it wants to become a Custom format if you try to change options. It simply didn’t give me the format options shown in the example you gave, only those two.

Throughout the whole of the last novel I wrote using MS Word I had to remove indents manually, so it would be great if Scrivener took care of it by default.

Thanks for your time

Ward: I don’t think Windows has these options yet. The assumption for those posting here is that they are running the latest Mac version of Scrivener. To avoid confusion in the future on both sides, it’s helpful if you choose your platform in the “User Control Panel” (link at the top of the page), so that it displays next to your posts.

I’m sure it’ll make it into the Windows version eventually. If it makes you feel any better, there were many years when this was not available to Mac, if I recall correctly.