Paragraph style keeps reverting back to default settings!

I’ve been trying out Scrivener for a few days. I should really have tested it a bit more thoroughly because I’ve just entered a large document a chapter at a time and then discovered it refuses to stay formatted!

I have folders set up under the DRAFT section for my chapters. In each folder I create a new page by hitting the ‘New Text button’. That new page always has a default setting of Palantino 13pt with multiple tabs set on the ruler, which I can find no way of changing. No worries. I created my own paragraph style using the font size I wanted with no tabs.

I can start writing text but as soon as I hit carriage return it instantly returns to the default setting of Palantino 13pt with multiple tabs set on the ruler.

It doesn’t matter if I select all of my text and then change it all to the same paragraph style, the moment I enter a carriage return it instantly reverts to the default format.

I can’t find anywhere in the preferences where this default setting is either.

I’d appreciate if anyone can help. I really don’t want to have to go back to Mac Pages and was hoping Scrivener was the cure for that nightmare, but not even Mac Pages switches paragraph style the moment you hit return.

Scrivener works on the basis that you’d don’t have a special style for the basic paragraph. Instead you simply use the default paragraph formatting. This can be found in two places:

  1. For all new documents in this and every other project: in Preferences > Editing > Formatting

  2. For all new documents in this project only: in Project > Project Settings > Formatting (make sure the ‘Use different default formatting for new documents in this project’ is ticked).

Both dialogues have a ‘dummy’ paragraph view where you can arrange the paragraph to look like you want it to. Alternatively, in the Editor, format a paragraph the way you like it, highlight it, then click Format > Style > Set default formatting.

With any of these ways, any new document you create will use your new default formatting.

You’ll have noticed the number of times that new appears above… that’s because setting the default is NOT retrospective. Instead, you have to select all the documents which use your ‘old’ default, and then click Documents > Convert > Text to default formatting. This does exactly what you’d expect it to do from the title…

Background… In general, styles in Scrivener work slightly differently from Word etc. There every paragraph has a style. In Scrivener you don’t need a special style for body paragraphs — you only use styles if you want to format text differently for some circumstances (e.g. Headings, Blockquotes etc). One advantage of this approach is that when you come to compile your document, Scrivener ‘knows’ how to translate the default formatting you’ve used into the correct formatting for your output. You don’t have to reformat the text for different outputs (manuscripts, ebooks, paperbacks etc): Scrivener does all that for you.

So, for example, you like writing in green Comic Sans 18pt. You can do that perfectly well in Scrivener. When you want to send the manuscript to a publisher, Scrivener knows to convert that Comic Sans to double spaced Courier 12pt when you choose the ‘Manuscript’ compilation option, just as it knows to use Palatino 11pt if you compile to paperback. In Word you’d have to change the format in the Editor for each output: with Scrivener it’s automatic.

I hope that explains the basics of what’s going on and why.

One final thing: can I suggest before you do anything else you do the interactive tutorial (on the Help menu). It only takes an hour or two and it’s the best way of learning the basic assumptions Scrivener makes, and will really help you get the best out of the program.

Hope this helps.

After reading what looks like a clear description above of how to change the default formatting and following the directions closely to select a section of text formatted the way I would like the default, I opened a new document with the same center justified 18 point Palatino Bold instead of the Left justified Helvetica Regular 12 point that I selected and set. I ran through it again and the only difference is the next document I opened was full justified–>still 18 still bold still palatino.
I have tried the interactive tutorial, but rarely can get to what I need. The struggle is real…

OK. Then let’s boil it down to a series of steps. I’m going to reduce any complexity down to the simplest possible arrangement. In particular, please note that this is going to affect every new document you create in this and every other project, even existing ones. Once you’ve got this working we can discuss how to make it apply to only this project, or the various shortcuts you can take.

To simplify matters, I’m not going to supply explanations (they’re in my first post), just the physical steps you must follow. None of the steps is optional — you must apply them all. Backup your project first for your peace of mind…

  1. Go to Project > Project Settings > Formatting.

  2. Make sure the setting Use different default formatting for new documents in this project is unticked.

[attachment=0]Screenshot 2021-03-13 at 09.31.49.png[/attachment]

[NB: Steps 1 and 2 are purely to make sure that we’re only setting the default formatting in one place: Preferences.]

  1. Close that dialogue and go to Preferences > Editing > Formatting. Does the text in the dummy text box look the way you want it to?

  2. If it doesn’t, then change it using the icons (starting with Aa for font and not forgetting to specify the line spacing, the alignment, and so on). Note how the dummy text reflects your changes. In this example, I’ve got Hoefler Text 12p left aligned with 1.5 line spacing.

[attachment=2]Screenshot 2021-03-13 at 09.05.49.png[/attachment]

  1. When you’re happy with the dummy text appearance (i.e. the ‘Default’ or ‘No Style’ formatting), close preferences and return to the editor.

  2. Press cmd-n to open a new document, and write a paragraph. It will be in the format you specified in step 4. i.e. you have changed the default ‘No Style’ formatting for new documents.

  3. But you have not yet converted previous documents, which still reflect the old default formatting. So, select all those previous documents in the binder and then click Documents > Convert > Text to default formatting. This step is essential.

  4. You will see this dialogue. In most cases you will be able to accept the defaults and just press Enter. All the selected documents will now have your new default paragraph format.

[attachment=1]Screenshot 2021-03-13 at 09.17.12.png[/attachment]

Do note that steps 7 & 8 will wipe out all previous formatting (except for specific styles you have applied to specific paragraphs) — you can alter that behaviour in the Convert dialogue, but most of the time it’s not necessary.

Also, note that Steps 7 & 8 will not update old documents in other projects — if you want other projects to reflect the new formatting, you must apply those step individually for each project you want to update.

That’s the basic process: as usual, it’s a lot more complicated to write down than it is to do in practice, when it boils down to “Change the default formatting in Preferences, then update your old documents.”

Hope this helps.

I’m having the same problem. I’ve used Scrivener for 6 months and only in the past week has it been ignoring all my default style settings, even in the same document I’ve been working on the entire time. It is SO distracting and SUCH a nuisance, I have been losing 10 minutes out of every hour, manually formatting each time I create a line break.

I have followed all the steps shown, as before, but it still reverts to Times New Roman 12pt at every new paragraph. Can it be that this is a new bug?

It’s impossible for any of us users to say if it’s a bug without seeing the project, but before you report it to the developers as a bug, I’d check the following points:

  1. Which version of Scrivener are you using, on which version of MacOS? The latest version is 3.2.2 – earlier versions had a few problems with Big Sur, which have since been corrected. (I don’t think this one one of the problems, but it’s worth updating anyway if you haven’t already.)

  2. Check the status of Project > Project Settings > Formatting > Use different default formatting for new documents in this project. If the box is ticked, then it doesn’t matter what changes you make in Preferences > Editing > Formatting, they simply won’t be applied to new documents in this project.

  3. Make sure you’ve applied the Document > Convert > Text to default formatting procedure to every document (after you’ve checked point 2 to confirm you’re changing the right default formatting).

  4. If all those have been done, then look closely at one of the documents where you’re seeing the problem. Do any of the paragraphs have styles associated with them? Converting old documents to the new format doesn’t change any paragraphs which already have a named style (unless you ask it to), and named styles can stipulate which other style follows them. Say your document has a paragraph with the named style “Body” and it’s set to be followed with another style “Normal” — that will still apply even after you’ve changed the default (‘No Style’) formatting.

Of course, I’m not saying that any of these apply in your case, but they would all show the behaviour you’re seeing, so they’re worth checking.

If you’re still seeing the same problem (and you can reproduce it with multiple projects or a new one), then perhaps you strip one of the offending projects down to its bare essentials (just one document which shows the problem) and post it here so people can have a look at what’s wrong?

HTH.

This is an old post, but I’m a recent convert to Scrivener (from Word) and encountered the same problem–after moving my novel from Word into Scrivener a couple of weeks ago, all was fine until today. Just like other posters, suddenly whenever I hit (carriage) return the paragraph style would revert to None. This hadn’t happened before today and I was at a loss how to fix, so I found this thread. Unfortunately, the answers didn’t help at all. I searched elsewhere and found the solution, and now all is good again. I won’t type it out in case this thread remains inactive, but if someone has the same issue and posts here, I will detail the very simple fix.

The simple fix is to redefine the “Next Style” setting for the style you’re using.

The fix that will work better in the long run is to not apply a style to your body text, using the default formatting instead.

Exactly! That answer was not provided earlier. Plus, a new user (like myself) might not even see that option because it’s not in the main paragraph styles window. As a recent convert from Word, I assigned a custom paragraph style to my text and a custom Chapter Heading style to my chapter headings–which I had always done in Word. But as I’m getting deeper into the workings of Scrivener, I might take your suggestion and use No Style, and make the changes when I compile. I did a “practice” compile of my novel early on, and there was something strange going on with Chapter Headings. Maybe that corrects itself if I change to No Style. Still trying to get used to the workflow. Thanks for your comments!

Recommend you “do” rather than “might”. Your life will be better. :wink:

3 Likes

It is in the dialog for defining every style, though.

1 Like