Paste without Links

I frequently copy from another program that embeds links in practically everything. When I paste this into Scrivener I have to spend a huge amount of time trying to remove the links and the resulting format. Is there a way to either globally remove links, or paste without links?

Paste and Match Style is the usual answer to pasting from web and other external sources (where what you want is the textual content, not the styling or embedded code. Does this not strip out linkage as well? (Not at my computer to test.)

(In fact, many of us have swapped the key commands between Paste And Match Style and regular Paste, because we almost always want the former when pasting text into Scrivener.)

1 Like

Is there a way to turn embedded links off in the other program?

I just tested “Paste and Match Style”. It works for new pastes–the text you paste with that command won’t have links. To get rid of old links you already pasted:

  1. Select all the text you pasted.
  2. Choose “Remove link” from the Edit menu. Even though the menu item says “link”, not “links”, it will remove all the links from your selection.

Note that the links will still be formatted like links, but they won’t be active. To force old pasted text to match your default Scrivener formatting:

  1. Select all the text you pasted (or just do this right after you do “Remove Link” while the text is still selected.)
  2. Choose some style from the Style menu. (Choose one that affects both paragraph and character formatting–it will have the symbols “¶a” in front of the style name.)
  3. Apply the style two times in a row.

Behold! the text now matches your default Scrivener formatting, the links are gone, and the link formatting is gone as well.

Hope this helps!

2 Likes

Well, that seemed to work. How does one swap the commands?

Just follow the steps in this knowledge base article to assign the two Paste commands the shortcuts you want to override the defaults.

1 Like

Thanks y’all for your answers! I’ve started using ‘paste and match formatting’, and assigned the normal ‘paste’ shortcut to that option. It all seems to be working great. Thanks again!!

3 Likes