Pasting comments from word to Scrivener--any way to have them automatically appear as comments not inline annotations?

When I paste text with comments from Word into Scrivener, the comments show up as in-line annotations. I searched through the sharing/import options and made sure that “import comments as in-line annotations” isn’t checked. Is there any way to change the behavior so that comments show up as comments when pasting into Scrivener. I know I can convert them afterward, but I go back and forth between word and Scrivener a lot because Word works so well with Dragon NaturallySpeaking so this would be a big help if possible. Thanks!

Have you tried importing the file, rather than copying and pasting?

1 Like

This is a bug in the setting that has been fixed for the next update.

1 Like

Great. Looking forward to it! And is there any way to preserve the original comment colors from Scrivener when pasting back and forth with Microsoft Word?

I’m not much of a Word expert, and have no access to it, but last I checked there is no colour setting on comments, but either way that information is lost on output.

I suggest, if you’re using colours and need to round-trip comments, using some form of text marking instead. I prefix each of my notes with a little code that indicates its kind, like “DEL” for deleted text, or “RWRI” for revision notes. I use colours as well, but only as embellishment. I find it makes things easier for working with them as well. Where there are searching tools for looking for comments and annotations by colour, its a bit of a fiddly tool that only searches the project one-by-one, whereas I can run a project search for “RWRI” and get everything in one go and it’s as simple as searching for anything else in the text.

Great suggestion. Thank you!