Persistent dialog when opening 1.54 projects in 2.2

Here’s a weird one for you!

When I double-click a project created in Scrivener 1.54 to open it in 2.2, I get the usual update window and everything works fine.

When I double-click an ALIAS pointing to that project (I made aliases of all my Scrivener projects to aid in reorganizing and updating them), the project still opens and updates. The normal dialogs about updating appear and disappear. AND THEN…

The last dialog to appear says:

Updating “[project name].scriv”
Updating project settings files…

Here’s a screen shot:

Scrivener update dialog.png

It just sits there. Forever, until I close it. No barber pole movement, no nothing. I checked Activity Monitor, and Scrivener is using zero CPU cycles at that point, so it isn’t actually DOING anything.

Oddly, this dialog often appears BEHIND the project window, so I only find it when I close the project.

The projects seem to work okay, and I can reopen them in Scrivener 2.2.

Nothing shows up in the Console log.

I’m running OS 10.5.8 on a MacBook 4,1 (dual core).


All the best,

Hi Joy,

Curious. I just tried this and it worked fine for me, but that was on Lion (I don’t have a Leopard system to hand at the moment). Does this happen with all 1.54 projects? Do they update okay regardless?


It happened on about 10 or 15 projects in a row, then stopped. ?!?

AFAIK all the projects updated just fine. (I have checked the contents of about 10 of the 30 or so projects.)

So, probably not bothering even to try to re-create it unless someone else reports it.

All the best,

Strange - it sounds as though it was just a case of the panel not closing. Next time it happens - if it does - could you please go to ~/Library/Application Support/Scrivener/Logs in the Finder, open the Console.log file you’ll find there in a plain text editor, and copy and paste its contents into your reply (if it’s not empty)?


All the best,