Placement of footnotes in compilation

I’m having two problems with footnotes in my compilation efforts:

  1. sometimes the main text prints on top of the footnotes, why is this happening?
  2. footnotes that are placed behind the full stop and closing quotation mark in Scrivener, appear between the full stop and closing quotation mark in the PDF or Word output. How can I remedy this?

Thanks in advance for your help,
Carine

What is your footnote anchor ? Does it encompass the whole thing ?
If you go to project settings, at the top of the “formatting” panel, there is an option to use inline a custom footnote anchor. That might fix your issue #2. Drop that anchor where you actually want the footnote ID to show up.

Ah, using footnote markers does solve the second item, thank you! (now I need to find a way to convert everything to footnote markers ;-0

You can insert the custom footnote anchor manually (without it being automatically inserted when adding a footnote with no selected text as anchor).
Use paste, as it needs to be exactly as it is in the project settings to be recognized as such at compile.
So, where you have a footnote that you want so anchored, manually paste the custom anchor where you want the footnote’s ID at compile, select it, then, in the original footnote, in the inspector, right click: move to current selection.

Using Inline footnotes instead of standard footnotes could be another option.

Thanks again! That is at least less cumbersome than copying and pasting the contents of footnotes! Inline footnotes are not an option I’m afraid

1 Like

Now that I think of it, perhaps you could simply insert a new footnote where you want the old one (in editor), copy paste the content from old to new (in inspector), then delete the old one. Might be faster to do than cautiously selecting the manually inserted custom anchor.

Less chances of user error, too.

1 Like

As for your issue #1, I don’t know. Looks like a bug. Perhaps retouch in LibreOffice afterwards ?

The thing is, I can only change the distance between lines in footnotes independently from the main text in PDF, not in word / LibreOffice.

(You should) Search the forum. Pretty sure I remember such an issue being addressed somewhere, in the past.
Keywords such as “overlap” and “footnote”

https://www.reddit.com/r/scrivener/comments/qopagc/footnotes_displaying_on_top_of_text_when/

There seems to be somewhat of a solution in there.

What seems to be the only valid hit I got from googling “Scrivener footnote overlap text PDF”

Thank you for all your help. I indeed first searched the forum, and I found one mention of the same problem, with no reactions to it. Exporting instead of compiling the file might be a solution, but then what’s the use of the compile function?

Well… Personally, I would in such a case compile to RTF and have LibreOffice convert to PDF.
It sure looks like a bug. (No software is perfect.)

Else, if there is an internal fix, @AmberV would know.

I think I’ve solved it! I saw the same topic in a different forum and someone suggested it might be a carriage return in a footnote or comment. I found them in both instances where the texts overlapped, deleted them and this solved the problem.

2 Likes