plain text

Is it possible to set my default Scrivener text (i.e., in the editor) as plain text?


Short answer, no.

Scrivener is RTF in the Editor.

I’m not sure what you’re wanting …

I write virtually all my content in Scrivener using Markdown. It has no Markdown shortcuts, but that’s not a problem for me. Easy to export files, or compile files, as TXT or markdown extensions.

So using basic markdown for plain text works terrifically. Imports plain text just fine also.

Do you mean: make the underlying file format .txt rather than .rtf?

If so, this has been discussed many times on the forum. Keith, the developer has said that the file format won’t be changing. There are very good reasons for that, and it doesn’t affect on Scrivener’s excellent ability to write and output multimarkdown (as the many users who do just that will attest…)

Or do you mean: make the text in the editor look like it’s plain text? If it’s the latter then there’s a pinned post by AmberV giving a set of preferences to do this: [url]]. (It’s for Scrivener 2, but the same techniques will apply.)

HTH – there are plenty of threads on both these issues, so have a look in the Multimarkdown forum and ask again if you have any questions.

Thanks for the quick replies. I’ll have to soldier on without plain text, I suppose.

Here’s what I’m after: I’d like to copy/paste a scene out of Scrivener and into an Alphasmart Neo, for portable, distraction-free tweaking–then later copy/paste the revised scene back into Scrivener. It’s the way I’d like to work. But I’m running into all kinds of problems with disappearing “smart quotes” and other related problems. Turning off the smart quotes isn’t a full fix because “smart” apostrophes (if that’s a thing) still pop up. Compiling in plain text format has the same problem. Anyway… I just need to find an easier way to grab a short section of plain text for transfer to the Neo. More experimentation is needed. Could be some Neo settings I’m overlooking.

Two options you might consider:

Scrivener’s Scratchpad, which writes text to an external folder accessible by other applications.

Scrivener’s Sync with External Folder feature, which does much the same thing, but with automation to facilitate re-integration back into Scrivener.

I’m not sure where the problem lies, but my guess is Neo. I have zero problems with plain text over the past 7 years. Scrivener is sooo reliable with plain text. I mix my text with code snippets (HTML, markdown, CSS sometimes) and Scrivener handles it all really well when I handoff to something else: my web design software, something like Byword or iA Writer, off to Marked 2 to be converted to HTML or a PDF, and so on and so forth.

I’m starting to think Neo doesn’t handle plain text so well. (I never use smart quotes so I can’t speak to that issue. I’m not even sure smart quotes is a “thing” when using plain text.)

There are 2 additional options, though you shouldn’t really need them. One is the app called PlainText. Download at Macupdate (if using a Mac). Auto turns all copied material into plain text. Ditto with Paste (Mac app store) which not only stores text and other stuff in a super clipboard, but can be set to do all copy/paste with plain text.

Thanks for the ideas, folks. I’ll explore your suggestions and hopefully one of them will do the trick.

You should not be getting curly apostrophes when Prefs > Auto-correction > Smart Quotes is turned off. That is, when you type a straight single-quote mark, it should not be turning into a smart apostrophe.

Is that what you are saying is happening?

(If it is existing curlies that are making trouble, you can straighten them in a whole document (or Scrivening of docs) after the fact with Edit > Transformations > Convert Quotes to Straight Quotes.)

That, specifically should not be a problem. I own and use a NEO with Scrivener and it is fantastic complement.

To clarify, have you double-checked that all options are off in the Edit/Substitutions submenu? I’d also go through the Corrections pane and make sure everything other than plain-text aids are off. I have never once seen a ’ character when I typed in ’ unless I have smart quotes on.

Technically speaking typographic quotes are plain text, and in that sense they are older and more well-supported among older editors than many of the other plain-text characters in the vast Unicode glyph set. What you are running into is how different plain-text formats address characters, that’s all.

If you give the NEO the right encoding then it will even display typographic quotes—it has those glyphs in the device’s font. The encoding it is looking for is Mac Roman, the old pre-Mac OS X encoding that nobody uses any more.

Granted, you can’t just copy UTF–8 and paste Mac Roman without some third-party assistance. There are probably many ways to do so, but as an owner of Keyboard Maestro, that is what I would use, to trigger iconv.

The above should be a bit academic though because Scrivener should and is capable of, when properly configured, dealing in pure ASCII.

In fact I updated that post the other day for v3. It now not only includes preferences for making Scrivener work more like a plain-text editor, but a sample font (Inconsolata XL) and a stylesheet with a vastly toned-down set of styles meant to compliment plain-text and look more like the kind of syntax highlighting a coding editor would be capable of doing.

At any rate, there are a lot of plain-text, Markdown, pure LaTeX and other users on this board—I’m one of them. We all use Scrivener as a host for our writings. Some of us use its formatting tools to our advantage—and there many advantages for doing so—others use none at all and typing every character by hand and with no embellishment.

The only times I ever find myself wishing Scrivener’s editor was different has nothing to with the incidental storage format it uses. I couldn’t care less what the disk has so long as I can get what I need out. What I sometimes miss are the extensive text editing control that editors like Vim give you. But, to be fair, nothing other than Vim really gives you that. Even the NEO feels paralytic in comparison. :slight_smile:

Yes, GR, that was what was happening. AmberV’s suggestion to also turn off smart quotes in Edit>Substitutions seems to have done the trick, though I’m not sure why the switch for that has to be flipped in two different places. In any case, the curly apostrophe problem seems to be resolved.

This operation seems to have no discernible effect. I need to experiment a little more and consult the manual.

AMBERV: Thanks for all the good information. I’m going to experiment later today with your preference file. That probably has everything I’m after. My formatting needs are pretty simple, and the plainest text possible, along with a couple of Markdown tags, are all I really need to do the job. My final output, if it goes anywhere, always goes to Word and then on to someone else. Thanks again.

There are two different switches because one impacts how new projects are set up and the other impacts how projects function after they have been created. You might need them for one project but not another—in the past you had to flip that global switch off while writing in one project, then flip it off when done. The new system is much nicer all around!

That in fact might be a macOS System Preferences: Keyboard: Text setting. Scrivener uses the underlying typography system for handling smart quotes, and there is weird issue with it in that if you set your smarts to be dumb quotes at the system level, then it loses the ability to straighten non-dumb quotes.

Handy, yes, but kind of tricky until you learn there’s more than one place to check. I need to spend more time with the manual. :slight_smile:

Thanks! I’ll look into that while I’m redoing my prefs later today.

AmberV, I’ve loaded your plain-text presets file, and I’m getting closer to my goal. I still have a few outstanding questions, though:

  1. The presets work as expected on new documents, but I can’t figure out how to apply that plain-text formatting over my entire existing project, which is what I’d really like to do. If you could at least point me to relevant sections of the manual, that would be a help–I’m having trouble finding it.

  2. On my existing pages, I now cannot get the smart quotes to turn dumb using the methods we discussed earlier. I’ve tried it with the relevant Mac text settings set both ways, and restarting each time, but to no avail.

Thanks for any help.


For the first question: once you’ve set the defaults in Preferences (or overridden them in Project Settings) then select all the documents you want to change in the binder, then Documents > Convert > Text to Default Formatting. You’ll get a dialogue box with various options.

The changes are non-reversible though, so test the process first for any unintended side effects.

Thank you, brookter. That worked like a charm. I appreciate it.
Now if I can get the curly quotes straightened out, all will be right with the world. Well, closer anyway.

Have you tried good old fashioned search and replace? Maybe the quotes are weird enough that the algorithm isn’t detecting them.

Mindreader. :slight_smile: I was just coming on here to say that very thing–I did a global search/replace for each one (left quote, right quote, and apostrophe) and that did the trick. I’ve done a little back-and-forth testing with the Neo, and all seems to be well.

It’s odd, though, that I couldn’t get Scrivener to make those changes, because the vast majority of the smart quotes that were in the project were ones that had originated in Scrivener itself, not in the Neo.

Thanks again for your help, AmberV. I’m in good shape now. Only thing left is to finish writing the book…