Please Help! No Page Break before Chapter Headings when compiling.

I am a new Scrivener 3 user (MAC). I never had Scrivener 2. I have completed my novel and in draft view, there are page breaks before each chapter heading. I have a folder for each chapter (level 1) and a text doc within each folder (level 2) to hold the text. When I tried to compile for printing, Chapter headings appeared at the bottom of some pages and in the middle of others with big spaces at the end of the previous chapters.
The draft view, in which I type, shows page breaks before each Chapter Heading. The middle section in the compile window appears to show an example layout with page breaks before the Chapter heading. However, it does not compile that way. I have read the manual and the layout settings appear to support the needed page breaks. But, when I hit the ‘test’ button, I get the same mess.
I have now wasted 3 hours (and several youtube videos) simply trying to set page breaks in a program that indicates they are already set.

Can someone please walk me through this?

Moved to Mac Scrivener support forum.

What Compile Format are you using? Which Section Layout have you assigned to the Chapters and to the text documents? (A screenshot would be helpful.)


Everything is by Default. I set the ‘Novel’ format and Scrivener set the rest. I clicked compile and did not set a compile format. I chose ‘to Print’ when prompted.[attachment=0]Screen Shot 2020-10-14 at 7.38.18 AM.png[/attachment][attachment=1]Screen Shot 2020-10-14 at 7.38.58 AM.png[/attachment]

Here is another look. The chapter is starting at the bottom of the page.

[attachment=0]Screen Shot 2020-10-14 at 7.47.38 AM.png[/attachment]

In the section layout assignment screen, scroll upward a couple of spots from the layout you’ve chosen for your Chapter Headings. You’ll see a layout with a “Page Break” line across the top. Choose that one instead. That should fix the issue.



Thank you so much!! That worked.

You wouldn’t happen to know if there is a select ‘all’ or de-select ‘all’ button on the right in Compile. When I only want to print some of my chapters it would be great if I could click one and hold shift and click to check box a particular range of chapters.
I only needed to print some of my chapters and I had to deselect 45 of them individually.
Thank you. very much!

Hold the option key to select/deselect all.

You can highlight a range of items the same way you do in Finder. First click on the title (not the check box) of the first item, then shift-click the title of the last one, then option-click any of the check boxes to check/uncheck all of the highlighted items. Do this multiple times for non-adjacent ranges.

Alternatively, you can select the items you want in the Binder, then choose the Current Selection from the Compile: dropdown menu.

– Katherine