(PLS advise on downgrade) Scrivener 3.1.5.0 Crashes - With Windows Event Log

TL;DR I can’t risk further work with 3.1.5.0 - please can you confirm/advise on reversion to 3.1.4.1?

UPDATE – I saved prefs and themes and uninstalled, then reinstalled 3.1.4.1 and reloaded basic prefs… theme seems to be there anyway - BUT didn’t restore dictionary setting (UK, not default US) and my personal dictionary/word list…??? NO, it’s gone? Where???

CORRECTION Personal word list is there but the Substitutions have gone. Please help me find them!

Windows Event Viewer Application Error fingers Qt6 - see end

(Windows 10 64-bit)

Happened yesterday, twice today so far. Cannot reproduce it reliably but, vague recollections & observations as follows.

  • Dual Screen setup - Scrivener on LHS on nVidia graphics card
  • “Started From the Beginning” message should appear in the middle of the active (lower) editor, and it always seems to if the dialog box is open, but if doing repeated F3 the message appears 1/3 of the way down the screen most of the time but has also appeared at the Top Right corner of the LH screen, overlapping Top Left corner of the (internal Intel GPU driven) RH screen (too ephemeral to take a screen shot)
  • Changing zoom on display of a folder does not leave currently found/selected text in screen, it scrolls to the bottom, but the selection probably hasn’t changed because F3 does throw up the “started from beginning” message
  • Oooh! I can make the “Started From the Beginning” jump around by repeated F3 and scrolling the doc between times at 150% zoom!
  • Put Scrivener on the other screen and behaviour is the same

And eventually, after I put it back on the LHS, try F3 a few times after which the message never occurs (or did it just get pushed into non-existent display space?), Scrivener crashes - just vanishes

Windows Event Viewer

Faulting application name: Scrivener.exe, version: 3.1.5.0, time stamp: 0x6492248b
Faulting module name: Qt6Core.dll, version: 6.4.3.0, time stamp: 0x64492733
Exception code: 0xc0000005
Fault offset: 0x00000000000b0367
Faulting process ID: 0xe60
Faulting application start time: 0x01d9a5a6039b0c96
Faulting application path: C:\Program Files\Scrivener3\Scrivener.exe
Faulting module path: C:\Program Files\Scrivener3\Qt6Core.dll
Report ID: ad98bf30-8bea-46c2-99f5-85106823292f
Faulting package full name:
Faulting package-relative application ID:

PS I wonder whether this is relevant… [BUG/ISSUE] Crash while searching · Issue #693 · marticliment/WingetUI · GitHub

To avoid polluting my own post too much: Substitutions issue resolved (but for how long???)

I inspected the contents of the prefs file reloaded after reinstalling 3.1.4.1 and the substitutions are there – and they probably were reloaded properly in the first place because I thought it was something I checked – but they disappeared, causing doubt and paranoia and the first icy chills of panic.

So I reloaded the prefs again and they are present… and working (phew!). But it did not go smoothly, this uninstall, reinstall, reload prefs etc. Scary.

@AmberV I hate to be a nuisance but… that app crash in 3.1.5.0? Well, the same just happened in the reverted 3.1.4.1 – alas no windows error log info (I looked). So I don’t know if it is a real Qt6 issue or not now.

I’m baffled, and worried – I downgraded because of the crashing, and it it still exists…!!! But I’ve never had these problems before? Is it just because I’m doing so much searching… in a folder with ~50 docs “merged” display in a single editor? (57k words).

The last Windows update was on 14 June and Scrivener is in intensive use every weekday – I’m proofing, so there’s been a lot more searching this week, but I have never had Scrivener crash on me like this before.

Recent updates (14 June) were KB5027215, KB5027538, KB5027797). I installed 3.1.5.0 on 21/06/2023 and the first observed crash occurred on the 22nd.

I do think my work flow may have changed – until very recently I only worked on a single document at a time, but now I am making more use of the outline and have this big folder all displayed at once, maybe it’s just too much? I am switching back to doc by doc editing to see if that makes a difference.

What diagnostic information can I provide to help?

Some of the oddness may be explained by loading a 3.1.5 .prefs file into 3.1.4.1, if that is indeed what you were doing. We had to fork to a new registry entry entirely for 3.1.5, mainly because of underlying incompatibilies with how strings are stored in UTF-8 and how font weights are addressed. If you have a 3.1.4 or earlier .prefs file to work from, that would be what you want to use.

Otherwise I suppose you could go through a 3.1.5 .prefs file with a text editor and remove everything relating to the setting of fonts. The AutoCorrection\substitutionList is also something you’d want to remove if you use non-ASCII-7 characters in it.

I do think my work flow may have changed – until very recently I only worked on a single document at a time, but now I am making more use of the outline and have this big folder all displayed at once, maybe it’s just too much? I am switching back to doc by doc editing to see if that makes a difference.

It’s worth a try, but in my experience there aren’t fundamental problems with that way of working. I very frequently load huge quantities of binder items into Scrivenings mode. Maybe not 57k words worth, though, to be fair.

As it has been several days since you posted this, I guess by now you’d have an idea if there appears to be a correlation?

Thank you, as usual, @AmberV, for the thoughtful reply.

TL;DR Search crash has gone away, but other issues are noted (not fatal, but important to know and maybe document?). Prefs probably not at fault.

The issue was reproducible then, but then is now a long time ago. Since then, everything has been uninstalled and reinstalled from scratch and now…? (That said, the 3.1.4.1->3.1.5.0->3.1.4.1->(complete uninstall and install from scratch) → 3.1.5.0 sequence has done something, I’m sure, but I can’t disentangle version incompatibilities from ab initio compile issues in 3.1.5 :frowning: )

To confirm: I’ve just retested this quite tediously on my laptop where a 3.1.4.1 installation now resides, having never seen 3.1.5: result - no crash

However the new issues… Find on Scrivenings doesn’t work properly with F3, that only does a “next” on the current document within the scrivening (and when it does loop around, the “started from beginning” message is squarely 3/4 off screen in the top right corner, so that’s not a multiscreen issue - the laptop only has one.)

Dialog Next/Previous however wraps around the whole scrivening.

Note that Home/End keys are also limited to the current document within the scrivening, but that might be by design (even though I have not found any way to get to the top/bottom of the whole scrivening other than by scroll bar)

I also reluctantly confirm the F3 & Dialog behaviour is exactly the same in 3.1.5 on the desktop. I checked the manual and I didn’t see anything to suggest F3 and the dialog should behave differently.

However, as noted somewhere :man_facepalming: , once I “discovered” the “same” issue in 3.1.4.1 on the desktop, when I realised I would have to uninstall and delete everything to restart from scratch, I installed 3.1.5 (hence some (?) compile issues?), so in fact the prefs I did save out and reimport are either 3.1.4.1 exported prefs in 3.1.5, or 3.1.5 in 3.1.5 prefs.

So it’s probably not prefs.

(I just had a look inside the prefs file and I didn’t see anything to indicate the source Scrivener version.)

My major issues at the moment are the borked compile formats (/functionality). If it’s not crashing and I know how to search a whole scrivening I can work, I just can’t compile.

I know it’s not customary for L&L to give specific timescales (I do understand), so I’m not going to ask for one, but if I might ask: how clear are the issues with compile, hence when, qualitatively, might we hope for a new release?

A. Soon
B. Soon-ish
C. Sooner rather than later
D. In the not too distant future
E. “At the appropriate time”

?

All right, glad to hear that the problem appears to be largely resolved or at least not commonly encountered.

My major issues at the moment are the borked compile formats…

Sorry, I don’t know what that is in reference to. A link to the thread where it is mentioned would help.

I didn’t want to drag you over to it just because I could create a linke. Either it comes up on your radar or it doesn’t. I’ve been noisy enough for a while – have a great weekend. Thanks :pray:

1 Like