Possible formatting strangeness through compile?

I hope that I’m not barking up the wrong tree here, but I have a problem in my workflow, including three possible ‘bad guys’ (Scrivener, Word for Mac, Bookends), and since many people seem to have a similar workflow, I’m looking for similar experiences and most of all a solution…
(THis has happened on my old Mac with Snow Leopard and Word 2004 and history repeats itself on the new one with Word 2011:)
I write a chapter in Scrivener, including all footnotes and in text citations from Bookends.
Then I compile it as rtf (because I thought at least, that this may be the most flexible, if I ever need to access the file from a Microsoft computer at uni, but anyway) and do my formatting and usually some proofreading in Word.
When I then scan the text with Bookends, the weirdness happens:
In the in text references (Author, Date: Page Number), Author and Date are font size 13, while the Page number comes out depending on the paragraph style. I work with five paragraph styles and it is the same in all of them. Also, I have to select each reference and put it back to size 12, because selecting the entire paragraph does not work. This is extremely annoying, I spent five hours just getting the formatting right after the scan for 190 pages…
The reason I think that maybe Scrivener is somehow involved here: The Bookends guy couldn’t really recreate the problem with the passage I (here comes) copied into a new document for him. I tried it myself, on my machine, and when a passage is copied and pasted into a new document, with all my styles maintained, Bookends works beautifully as it should. Also, I made a little lorem ipsum text document (without Scrivener involved) in word, with my styles, and it just worked fine…
I’d be immensely grateful for any hints or ideas where to look and how to fix this (or whom to ask if it has nothing at all to do with Scrivener), because I simply don’t have the time to do this everytime in my workflow… sigh…

What happens if you open the RTF document in Word, save as .DOC, and then do the Bookends scan on the DOC file? Or is that already what you’re doing? It isn’t quite clear from your note.

I don’t have any particular ideas about the problem, but that experiment might help narrow it down. (And provide a workaround if it works.)


Hello and thanks for your reply. Actually, it happens in both cases.
I somehow have the feeling that there is a box I don’t or do tick in the compile settings maybe, something about to do with overriding? Maybe it does not hark back to Scrivener at all, but this phenomenon, as I said, only seems to occur where Scrivener is involved… :confused:

Looking at things logically (I think) Bookends will, during the scan, strip out the part of the temporary citation that consists of author, date, and ID number – i.e. {Smith, 1989 #100 – and replace them with text from its database. But the page number can only come from text typed in by the author – it must therefore be extracted and stored during the scan, and added to the final citation, usually at the end of the text that Bookends has taken from its database. I wonder if formatting information is being retained by the page number, while the main text of the final citation is coming through from Bookends as plain text (or as text formatted in 13pt). Bear in mind that in Bookends you can go Biblio > Formats Manager … and change the point size of the text that is used for the citation. But perhaps you’ve already tried that.


Good thinking that :slight_smile: . At least this would explain why the page number behaves differently from the messed-up rest! As to the Biblio>Formats Manager: I can’t find that option there, but in Preferences>General all default font sizes are set to 12. Yet, this does not quite explain why this problem does not happen when I scan a text I’ve written entirely in Word. If it had something to do with the Bookends settings themselves, I suppose it should happen then as well?
I’ve also tried to copy and paste the entire 190 pages monster into a new word document and scan it, as that had worked with randomly chosen chunks, but the same annoying size 13 fonts turned up again… This is really driving me nuts!

I suspect that the interaction between Word and Bookends works differently from the scanning of an rtf file, though I may be wrong.

Which format are you using? (APA, Harvard?) Does it use a custom citation format? For example, APA uses a special format for citations, which appears (if you select Biblio > Formats Manager …) as a separate item in the list of formats (APA 6th Citations). If you select it, you will be able to see Formatting Options in the right hand panel. If you then select text in the text box, and go to the top menu bar item Style, you can choose whether the text is Plain, Italic, etc., and the font size. Have a look and see what settings you have.

You can also “normalise” the fonts you have in references by going to Refs > Global Change > Restore Default Font and Style.

The default fonts in Preferences > General do not refer to scanned documents. They refer to fonts used within the program itself, or to bibliographies produced by the program from selected references inside the program (by going to Biblio > Bibliography Formatter). (Unless I’m mistaken.)


Can you create a test file with a small number of pages and a small number of citations? That might be a bit easier to troubleshoot than the full 190 page original. The fastest way would be to use the Compile -> Contents options to only compile part of your manuscript.


@mbbuntu: Thanks for the hints. Well, I have looked at the style in the citations (I use Oxford Author-Date at the moment) and it all looks fine to me. Also, again, I think if it had something to do with the Bookends settings, it would occur in every document, and not just in this one?
@kewms: I di what you suggested and created a test document within the Scrivener project, compiled it as rtf, opened it in Word, applied my styles and scanned it. Et voila, the same thing happens. Where should I send the files so you can have a look? And thanks so much!

A rather obvious question: what do the temporary citations look like (1) in Scrivener; (2) in the virgin rtf file before anything has been done to it; (3) after you have formatted the text in Word?

You will need to be very careful in looking at this: remember that even a single space can have a different formatting from the text around it. It is possible that formatting before or after the temporary citation is being picked up and used when the scanning happens. If not, then it must, perforce, be Bookends that is causing a change to happen when the scan is carried out.

Cheers, Martin.

Hi, ok they look

  1. fine in Scrivener
  2. fine in the untouched rtf
  3. fine after I have applied the styles in Word to the paragraphs
  4. horrid after the scan

It seems to me that you have your answer, then. It is something that Bookends is doing during the scan. I can’t think of any other explanation.

Cheers, Martin.

One last thing to check. In Word, turn all the View options on so that you can see paragraph markers and other hidden formatting commands. If that doesn’t reveal anything, then it pretty much has to be a Bookends problem.


Thanks Martin and Katherine,

I’m still not quite sure how to solve this problem, but will pursue the Bookends ‘line of enquiry.’ One last thought though, since I have not much expert knowledge of formatting etc.: Would it be a possibility at all to take the entire word document and kind of ‘de-format’ everything in there and apply ‘clean’ styles that worked with Bookends before?

Yes. There are various things you could do. In Word, you could simply select all the text (Cmd-A) and apply a style that “normalises” the whole lot, or you could search for formatting (just bring up the Find dialogue and choose the appropriate option), or you could paste the text into TextEdit and save it as plain text instead of rtf. You could install the free services that can be found on the DevonTechnologies web-site (which I think include a service for stripping out formatting, though I might be confusing them with another service). In short, there are many ways of getting a “plain vanilla” text file, if that’s what you want. You might even be able to get one by compiling from Scrivener, but I’ve never tried that. Probably the fastest thing you can do is to do a formatting Find and Replace within Word: just search for 13pt font size, or whatever, and replace with 12pt. I’d seriously advise you to study the manual on Find and Replace for formatting – even do a Google search for tutorials – from what you’ve written before, it’s possible you’ve been doing a lot of unnecessary work by hand.


Thank you very much :smiley: . I’ll look into this, and I think “vanilla” is what I want! In fact, I did the search and replace style, but then I had some styles in the main document that had font size 10 or 11, not 12 like the main body, so that wasn’t feasible after all (plus, it was 1:30 in the morning before a deadline, with a whole day of being annoyed behind me, so maybe I wasn’t thinking clearly).
Anyway, thanks so much for all your support (even if it mainly concerned other products!), I really appreciate this!

Not at all. I hope you manage to sort it out.

Cheers, Martin.