Post-hoc formatting issues

I’m importing texts written in Libre Office into Scrivener. Cut and paste works fine, but the chapters are in a variety of different fonts, faces, and formats. I want to get them all coherent, but ‘make formatting default’ doesn’t seem to do what I thought it would. I want to select the whole Scrivener document and apply a format to it, and have that format be the default format of the document. How do I do this?

Set a default format in Options, then select documents and use Documents▸Convert▸Convert to Default formatting. When you say “the document”, you may mean “the project”, but that’s not what Scrivener calls a document. This conversion doesn’t affect text that you’ve given a named style; those should be fine.

1 Like

Thanks. I’ll give that a try.

Hmmm… that seems to work except for the first line indentation. Is there a way to make that included in the conversion?

No, but there’s a Compile setting to turn off the first line indent.

Hmm… I don’t think I want to compile it, it’s still a work in progress, but I want half-inch first line indents and not all of the imported documents have them. Is there a way to ‘select all’ for the entire project, or the entire book part of it, at least? I have a lot of parts and I think that going through them scene by scene is going to be time consuming and error-prone.

You can set the first line indent in the default formatting:

That’ll indent the first line of all your paragraphs. (Excluding those to which you applied a style.)
If you want an indent for only the first line of your documents, it could be done (using styles), but it ain’t worth getting into that at this early stage. (A whole lot of tweaking just so that it uselessly – for the time being, the least – looks a bit nicer in the editor.)
Better wait to be almost ready to compile.

Same goes if you rather meant that you want an indent everywhere but the first line of a document. In which case, set the indent in your default formatting, then as said @drmajorbob, you’ll simply have to later check the option to remove it from the first paragraph of a document, at compile, in your compile format.
(As you can see, this is not only more of a standard way to format a book, but also way easier to do than to format the indents the other way around.)

Thanks, but this doesn’t seem to work for me. I want to have a paragraph indent for all paragraphs in the project, but there’s already lots of scenes with a variety of indents. Is there a way to do this for the whole project? It will only let me ‘select all’ the bottom level folder contents.

Just add the indent to your default formatting in the options (my screenshot), then reselect all your documents (in the binder, not their text in the editor), and convert to default formatting like you’ve done before.

There’s never any reason not to Compile it. The sooner you start, the sooner you’ll master it.

I don’t quite understand what that last statement means, but this knowledge base article covers both setting, and then bulk applying, default formatting to existing documents.

The article doesn’t go into the wide variety of ways in which one might bulk select items in Scrivener though. Some useful tips:

  • Click on the magnifying glass button in the main toolbar, and then running a project search for * (one asterisk). This is a shorthand for “find everything”. From that search result list you can use ⌘A / Ctrl+A to select everything and reset the formatting to default. Just be careful when doing this, as that might do a lot more than you want (like blowing away formatting in research documents and such).
  • If you just want to do this to one main folder (like Draft), then click on it by itself, and switch to View ▸ Outline. Click into the outliner in the editor, and press ⌘9 / Ctrl+9 to invoke the View ▸ Outline ▸ Expand All command, toward the bottom of the View menu. Now you’ve got an easy place to “Select All” from that doesn’t disturb your binder layout.

Be aware the stuff you import into Scrivener, especially if coming from a variety of sources or periods of time, may not be formatted “properly” in the sense that some use tab characters at the beginning of paragraphs to fake the appearance of indenting. As tabs are literal characters, no amount of attempting to format the indent out of the paragraph will work, and can cause some paragraphs to look “double indented”. Fortunately we do have a command for cleaning up this common problem in the Edit ▸ Text Tidying ▸ submenu.

2 Likes