Preferences > Text Editing > Script Text Attributes -

Lucida Typewriter Std has been my fixed width typeface of choice for some time; from Terminal to IDEs.

For some reason Scrivener interrupts me with a fixed pitch nag any time I apply a tweak to my Scrivener preferences. My apologies if I’m somehow mistaken, but as Lucida Typewriter Std is a monospaced typeface, the fixed pitch nag might want to expand it’s inclusions.

This is a weird Apple thing - the same happens for Courier. Scrivener just uses Apple’s -isFixedPitch method on the font, which returns YES if the Apple font system thinks the font is fixed pitch and NO if not. If NO is returned, the error is spewed.

I’ll probably get rid of the error altogether in 1.04, though, given that the way script settings are set up is changing again.

All the best,