Prefs won't change

An odd problem. I’ve changed Scrivener’s text preferences so that sentences should start with a capital letter - but Scrivener isn’t auto-changing the letter to a capital. Is there a solution? Keith? (Kevin?)

Are you in script mode? That has different capitalisation settings. Also, did you make sure you pressed “OK” or “Apply” in the Preferences? And note that it will only capitalise a word after a space or return is created after it.

All the best,

Yes there is. Well have to change Grumpys handle to: ‘Gloria’.

Pressed Apply, restarted Scrivener, rebooted computer.

By script mode do you mean a mode for screenwriting? No - in the ordinary mode invoked by ‘New Project’ and then ‘Empty Project’.

Can you describe exactly what you are typing, at what point you expect something to get capitalised, and exactly what is happening instead?


I’m typing away like this, and pressing a full stop at the end of the sentence. As I keep typing, without hitting any capitals, the ‘i’ and ‘i’m’ turn into ‘I’ and ‘I’m’ - but the ‘at’ of ‘as’ doesn’t change to ‘As’.

Similarly, when I press ‘return’ (also selected in the prefs), it doesn’t capitalise the next letter. Not so fussed about that, actually. But it would be nice to have an auto-capital after a full stop.

Have you definitely got “Capitalize first letter of sentences” checked in the preferences as well as “Capitalize ‘i’”? These are two separate settings (because not all languages want “i” capitalising).

All the best,


About the only thing I don’t have checked is ‘Enable subversion’. Whaddaya think I am, some kinda Commie?

Could you post a screenshot of both your preferences Text Editing pane and your main screen? Just so I can rule out anything obvious. Thanks!

Keith - Here’s a screenshot.

Oops, sorry, I see, looking at this, that there are two places to check ‘Capitalize first letter of sentences’! Maybe we have it now! Hang on, will try…


Sorry - I’d checked one, and never saw the other!

Ah, yes, when I said that script mode has different capitalisation settings, that’s what I meant - sorry, I should have been more clear and actually said where they were!

Glad you found it.
All the best,

What do the two settings do, Keith? (And what is script mode?)

Script mode is for scriptwriters (Text > Scriptwriting > Script Mode). Because scriptwriters don’t want things like parenthetical sentences capitalised and because Scrivener 1.x isn’t very good at telling the difference, it allows the user to choose different auto-caps methods for each mode. 2.0 is smarter and won’t require different settings for different modes.
All the best,

Ah, I see. So if I’m in script mode I turn off the top one of the capitalization choices in the Preferences? Thanks.

No, the one under “Script Text Attributes” to turn off caps for script mode…