preserving styles in new documents

I set the preferences to set new note styles from the current document, but new documents do not preserve my established styles. Am I doing something wrong?

Hmm, this should be working for you, I just gave it a quick test to verify that nothing has been broken here. The important thing is to make sure that the last document you clicked on has the styles you want to set up as default, before clicking that button in preferences. Here is the checklist I followed:

  1. Created a new empty board with a single note.
  2. I styled this note to be centre-aligned and underscored.
  3. With the note selected, I used Format/Note Style/New Note Style from Selection. I called it “Simple Title” and saved it with default settings.
  4. Verified that the “Simple Title” style was listed among the standard defaults.
  5. Opened Preferences with Cmd-,
  6. Clicked the Set From Current Document button and closed preferences.
  7. Hit Cmd-N to create a new board and checked the style menu. “Simple Title” was listed as expected.

Following that checklist, do you get a different result? If that worked for you, perhaps there is something wrong with the styles you have set up in the example document. Would you mind attaching it, or a copy of it with all of the notes deleted, to a response?

I think I was trying to use my defined styles with an existing document as opposed to a new one.
I’m assuming they only show up for new documents.

Ah, yes that is the case; Scapple doesn’t even really “know” of any files you’ve already created unless they are open—but even for the open ones it would be presuming a lot to say that their styles should be overwritten. That’s something you have to commit to, so if you want to bring in styles to an existing document, you can do so with Format/Note Style/Import Note Styles... and then select the .scap file that has the styles you wish to import.

I’m having the same problem but I don’t know what you mean by opened preferences with the Cmd key. I do know it is not Cmd P.

Here is what I’m trying to do

create a series of notes with

  • 11 point font of may choosing
  • blue background in note
  • default cream background

But nly the default font seems to change. I can change fonts but not other controls.

Everytime I create a new note it’s back to 14 point, cream bg :frowning: :frowning:

I save as a Note style
I return to note styles to redefine it and it’s not there.
I save the scap file and the style is there but not what I want.

I just can’t seem to get the hang of it. It’s making me stupid. I have an hour of reading the manual and experimenting with the tools.

If you’re trying to set the default note style for all new notes (across all boards), this is done in the New Notes tab of Scapple > Preferences. You can set the font size and note fill colour here.

The font and the background colour of the board is set in the inspector, View > Show Inspector, in the Document tab. (By clicking Set As Defaults here, you can also make these settings the defaults for all new boards you create.) You can only have one font per board, although you can adjust the font size of different notes by selecting them and adjusting the slider/size setting in the note style tab of the Inspector.

To save a new note style that you can apply to selected notes, create a new note and use the Note Style options in the inspector to format its size, fill color, and any other options there that you like, then (with that note still selected) choose Format > Note Style > New Note Style From Selection. Give the style a name and check the boxes for the style settings you want to save (deselect those you don’t); you’ll at least one “include font size and style” and “include background and border style”.

You can then apply that to other notes on that board by selecting the notes and choosing the saved style from Format > Note Style > Apply Note Style. If you want the style to be available for new boards you create, ensure that this Scapple document is focused (just click into it) then open Scapple > Preferences and in the General tab, click “Set From Current Documents” to make that document’s list of note styles the new defaults for new documents.

To get the saved style into an existing Scapple document, open that document and then choose Format > Note Style > Import Note Styles… and select the Scapple document file that contains the new note style. So for example if you have documents A and B and create the new note style with size 11 font and a blue background in document B, you could open document A, select Import Note Styles… and choose document B in the file browser to import its note styles into A.

Thanks you MimeticMouton, for your detailed explanation and patience.

Making changes in Preferences was so obviously the answer that I simply could not see it. I got hung up on the Set Default button in the Inspector as an overall change agent. I think my brain was trying to take the weekend off. It certainly did get muddled and impatient. :blush:

I owe you a lunch if ever I get to the City of Rain (Seattle?). Thanks again.