Problem compiling for MS Word

When I compile for MS Word, either as a .doc or .docx, I get square brackets around the titles. How do I get rid of those?

It’s hard to say without more information on what you’re doing, and what conditions are required for these brackets to appear. For example do they appear at all if you use PDF, or HTML to compile? Do they appear if you open the .doc file in LibreOffice, or even drop it back into Scrivener itself? Where are the titles coming from, are they typed into the editor or are they being generated by Scrivener during compile, based on binder titles—or something else?

I am compiling a synopsis.

The brackets appear if I compile for a Word format and open the document in Word. They also appear if I compile an .rtf document compatible with Word and open it in Word. They appear nowhere else but in Word.

The titles are folder titles from the binder.

Okay, I’m not too much of a Word expert, so this may be something that someone more familiar with the software may instantly recognise. I would wonder if the brackets print from Word, or if they seem to be invisible once you print (or just preview the print to save paper). It could be they are some kind of code that is being expressed visually, like you can set Word to show token code instead of the printed output, for things like cross-references and bookmarks?

AHA! :blush: The light dawns! I thought they looked familiar. I am something of a Word expert, but bookmarks are a feature I have used very little (but probably should have). Your suggestion made me look at the compile dialog box again. The default is to “Include in RTF bookmarks.” Unchecking that box solves the problem. It has to be done for every level of formatting.

I find most things in Scrivener fairly intuitive. The Formatting section of the Compile dialog is NOT one of them. :confused:

Thanks for your help.

Those square brackets aren’t added by Scrivener - it’s just that the default preference in Word places square brackets around bookmarked phrases so that you can pick them out easily (but it doesn’t print them - Word just uses them for display only).

To hide the square brackets in Word, go to Word > Preferences…, and deselect “Bookmarks” in the View pane.

Of course, you can equally strip out bookmarks altogether, as you have done, although that will mean that page number references won’t work in the compiled document should you include any, or if you include a table of contents.

As for Compile, it is a bit of a beast, but there’s not much of a way around that if it is to accommodate any possible format with any possible binder structure and any possible workflow - it either has to be simple and rigid, or flexible and complex.

Bookmarks are a highly useful feature of Word, often neglected (me, too) but I have a nasty feeling MS will remove the feature in the next version in favor of more eye candy and dead weight. Microsoft, being the 750 pound rabid guerrilla (no, not a mistaken use of the word) does whatever it pleases.

Enough vitriol.

What confuses me most about the formatting pane of the Compile dialog is the relationship between the various levels, which does not seem to mirror the structure of the binder. Intuitively, it seems that it should, rather than reflect it with a somewhat different order. :confused:

I fully understand that often, flexible = complex 8); and that complex does not necessarily ≠ intuitive; and that intuitive may not = obvious. Adobe, for example, delights in making things non-obvious, but intuitive once you see how it’s done. I hope the formatting pane of Compile is like that.