Problem when inserting an accent (Spanish writing)


I am finding a problem when trying to insert an accent/mark/(I am not exactly sure how it is called in English, but it is like when in Spanish you want to stress a syllabus, like ‘prisión’, ‘Proponía’, etc…)

There is a key in the keyboard which is there to be clicked before you enter the vowel that should have the accent.

So, for instance, I try to write “proponía” in Scrivener, but it writes “propon´ia”.

Please, could you have a look at this and let me know if this is a bud and how could it be fixed? It’s driving me a bit crazy, cause we use those accents one every 374 words, and I can’t keep my writing at good pace with this problem.

Best wishes,


Someone else has reported this problem but for them it is only happening in Scrivener’s Scratch Pad. Are you seeing this everywhere in Scrivener, even the main editor? I’m afraid we’ve been unable to reproduce it and we’ve only had these two reports of it so far, so something specific must be happening somewhere.

Please try booting in Safe Mode (reboot and hold down Shift until the login screen appears) - do accents work in Scrivener in Safe Mode?

All the best,

I’m glad someone post this problem, because I’m having exactly the same.

I think it’s happening since I installed Scrivener in Mac Sierra OS, because I don’t remember having that problem with my old Mountain Lion OS. It’s really uncomfortable indeed, because it makes writing in Scrivener almost impossible. To write an accent, sometimes it works and sometimes it doesn’t and just writes “qu´e”, for example, instead of “qué”. That is, it doesn’t recognize the accent as such but as a simple quote. To have it working, I have to go back, delete the whole word and retype several times, so it’s impossible to mantain an accurate writing speed.

I’ve also noticed something that may provide a clue. If I change my keyboard settings from “Spanish - ISO” to “Spanish” (i.e., in System preferences - keyboard - input sources - add new"), it seems to work correctly. The problem is that in Spain our keyboards are designed for the “Spanish - ISO” key layout, so the “Spanish” layout has the accents in weird physical keys.

It would be great if you can locate the bug. If you need more info, just tell me. I’ll be happy to provide whatever is needed :slight_smile:

My system: Mac OS Sierra 10.12.6


I thought I’d fixed this bug in Scrivener 3, actually.

  1. Which version of Scrivener are you running?

  2. Does the problem happen in scrivenings mode, viewing single documents or both?

  3. Do you have automatic completions turned on in the Preferences?

Thanks and all the best,

Thanks for the answer, Keith!

I’m using Scrivener 2 (I forgot to mention it). Anyway, browsing through the forum I’ve just found a post from another user with the same problem, and he identified that it only happened with the Autocomplete feature on. I don’t mind having it checked off, so I can work with it that way :slight_smile:

(This is the post, btw, if you want to take a look at it:

Glad you’ve found a way around it. What version of Scrivener 2 are you on, though? This should have been fixed in a later version of 2.x, and I can’t reproduce it. What exactly do you need to press to see the problem?


I just ran into the same problem, using Scrivener 3, on Mac Os 10.12.6 (Sierra). Luckily the problem seems to affect a single project.
It just started out of the blue (I have written whole books in Spanish in Scrivener without a hitch for 5 years now). Now, I can’t write a single accented word in that project. I have tried changing keyboard layouts, and it was no help.
In version 2, this problem existed in Scriptwriting mode only. But I tried switching from one to the other and it didn’t help either.
Maybe I (and the other persons in this thread) accidentally changed an option that tripped this change. What could it be?

Please find a solution for this bug. For people who write in Spanish it is impossible to write without adequate accenting.
Thanks for your help

Sorry to say, but telling me to find a solution is easy compared to finding my a solution for something I cannot reproduce. I’ve been through code and am hopeful that I have made improvements for 3.0.3, but if you can provide specific instructions on how to reproduce the issue, that would be a tremendous help.