Problem with auto caps option in Turkish

I write in Turkish and I use the auto caps (automatic uppercase) option in the script mode.

In Turkish lowercase i refers to İ and lowercase ı to I. However scrivener makes them both I.

I believe this happens because scrivener doesn’t set any language properties (unlike MS word which doesn’t have this problem) to the text and converts i only according to English language.

Is there a way to overcome this? Otherwise I cannot use the auto caps option which is very handy.

Regards
Oymen