Problem with Importing

I had inadvertently posted this in the IOS Thread, but it is happening on my Mac so I am reposting here…

I am collecting information for writing by Doctoral Thesis, I am running Scrivener under OSX Sierra. Previously, under “El Capitan” everything worked fine.

I would import web pages by going to safari and saving the page, and then going to scrivener and doing an import files. This used to work under El Capitan - UNder Sierra, the moment I go to Import files - scrivener crashes. Now it has been suggested that as an ALternative, I can go to “import webpages” and plug in the URL as appropriate - the problem there is that a number of webpages have annoying popups - in a firefox or safari browser, I can close those popups and then save the “page” - because Scrivener has it’s own embedded Browser for picking up websites, I don’t get that option, and the saved page in Scrivener is blocked by the popup.

I reported this as a fault, and was told that it would have to go to the developers - and that is the last I heard.

So, Importing a web page as a “file” from a saved Webpage export doesn’t work. Even if it did, popups make this useless.

Importing any other file (PDF) from the drop down menu, also fails - I can get around that, by dragging and dropping said files into the binder, but the other approach should work.

And if this rates a devo fix, am I likely to see more feedback on this, or is it a wait for the next release, thing…

I know that one of Scrivener’s strong points is its ability to keep related material in the Research section, but if you need a way to collect a lot of information from the web and to organise it, I think you should look at e.g. Evernote, which has a very qualified web clipper and is good at organising stuff. Use each app for what it is specialised at doing.


I saved this thread page as a “web archive” and as “page source” in Safari. Both versions of the page imported into Scrivener without any error, using File > Import > Files.

I am also running macOS Sierra 10.12.1.

Have you installed the latest Sierra-compatible build of Scrivener?

If you haven’t, that might be at the root of the issue.

If you have, perhaps your Scrivener installation has developed a localised glitch, and it might be worth deleting it from your Applications folder and then reinstalling it from a fresh download.

Well, I have deleted Scrivener (from applications) - reinstalled the latest kit from the download location on the net. Same problem. I did not that the crash error message, said something about it happening in quicklook.pluginload. So I uninstalled all of the plugin handlers I had - no change.

Crashed Thread: 12 Dispatch queue: quicklook.pluginload

Exception Codes: 0x0000000000000002, 0x0000000000000000

Termination Signal: Trace/BPT trap: 5
Termination Reason: Namespace SIGNAL, Code 0x5
Terminating Process: exc handler [0]

Thread 0:: Di

Given that your main goal is to clean the page to what is important, have you tried switching your settings in the Import/Export pane to convert pages to text instead of WebArchive? I tend to find that whole architecture to be far more complicated, slow, not really archived and error prone than for what I need of it: preserving the text of a web page.

That aside, I recall looking into this for you a while back when you wrote in, and there isn’t anything we can do about it. The crash occurs when Apple’s display engine loads Apple’s file format which was created with Apple’s framework for doing so. All we’re doing is asking macOS to do these various things and show the results in the editor pane, and if it crashes while doing so, it takes down the whole program with it in such a way that we cannot block or contain it. Apologies if that fact was not adequately relayed to you when you wrote in—and sorry we don’t have a better answer than that, either.

It might be using the Quick Look engine for some of this, I don’t know, but if so it wouldn’t be any engines you installed, it would be the WebKit stuff that comes installed with 10.12 and is core to the OS.

As we noted to you before, the problem is not universal. Some pages work fine, others crash. No doubt it has something to do with what the web developers have done that Apple hasn’t anticipated in their code, or perhaps in the plug-ins you are using to clean up the page.

Just to be clear, there are two different, but suspect to be related problems.

  1. If I go to import a web page, it has no way of clearing popups etc, before grabbing the content of the page - which means that what I end up seeing is covered by the popup. Which is why, I was using the Safari “save as” to first clear the targetted web page, save it, and then import it as a file into Scrivener. An “import web page” works, but ends up with junk on the saved image which makes it useless as a function.


  1. If I go to import a file, as soon as I get to the “select a file” from a directory, it crashes - I haven’t selected a file, nothing. I can get around this, by dragging and dropping files (pdfs etc) onto scrivener, but if a drag and drop works, a select file dialogue should - it is one of the simplest and most common functions in any file manipulation interchange.

If the import file dialogue is crashing immediately, before you use it, that would be very unusual. Do you use any programs that modify file dialogues in general, or have you in the past, like DefaultFolderX? If so it might be worth looking into updates for them, or trying without them installed to see if the problem is related.

A safe boot is a good way of checking for issues along those lines. If you reboot and hold down the Shift key after the chime that will start a safe boot, which turns off all complex drivers, kernel extensions, background programs and so on, giving a you a very vanilla environment to test in. You wouldn’t want to use the Mac that way, but as a diagnostic tool.

I don’t use DefaultfolderX, or anything similar to my knowledge and what software I do use, I have scripted to update weekly.

I tried a safe boot, and still had the same problem.

I noted the quicklook.pluginload error, and did some googling on that, and came across something that suggested moving a quicklook .plist so that a fresh one could be built. No joy there, either.

Hmm, this is a very “vanilla” macOS panel, which is what makes the problem extra puzzling. There isn’t even any auxiliary code for optional checkboxes and such. The only variability I can think of, that would make it different from other similar panels (I’m assuming you have no problems with for example File/Import/Plain Text Formatted Screenplay…) is the last known location it was attempting to use. It returns to where you used it last, do you get far enough into the dialogue to see where that is, and maybe go there in Finder and check for files with large thumbnails—anything potentially out of the ordinary? Also if you use any of the advanced features, like Spotlight search or whatnot?

Well, if you haven’t already you could try a preference reset. You can save your settings prior to doing so with the Manage button in Preferences, then close the software, remove the com.literatureandlatte.scrivener2.plist file from ~/Library/Preferences, log out and back in to flush preference caches, and then from a clean slate try importing. If that worked, import your settings from the backup file you created.

That will at least reset the “last used” tokens and revert these file dialogues back to ~/Documents.

Sorry about the delay in follow up - I have been out of internet range for a few weeks. (Cruise Ship) - Tried saving the settings (with the manage button in preferences) that appears to try to open the Desktop Folder -

I have also noticed that an attempt to open another Project crashed.

Opening Recent works fine, and opening via spotlight search works fine…

Well if you can’t save your settings before resetting preferences it just means you’ll have to go through and set things up again afterwards. It is possible to test whether or not a preference reset will help, by moving the .plist file elsewhere instead of trashing it. If the problem lingers you can restore the file and retain your settings.