Problem with new boards/notes


Machine: M2Pro Mac Mini, 16GB
System: MacOS Sonoma 14.4.1
Scapple version:


  1. Create a new blank project;
  2. Double click to create a new note;
  3. Type something, e.g. “Start typing”

Expected behaviour

The new note is created with the text “New Note”. Click into it for editing:

As I start typing, that text should disappear and be replaced with what I am typing.

Actual behaviour

What I type overlays the text “New Note”:

The “New Note” text only disappears when I click out of the note after typing a bit and click back in to continue editing.

On occasion, clicking the red traffic light while the cursor is still in the note with the “New Note” text partially covered as in the second screenshot causes Scapple to hang. I had this happen twice this morning during testing… in each case I was testing with opt-i i as per:

Here’s the report, if it will help: (270.5 KB)

I haven’t been able to narrow down if I did something different to cause the hang,

1 Like

Thanks! The placeholder text overlap issue is filed.

As for the hang, I haven’t seen that when trying to close while editing, but the log you sent does not look like the one caused by pressing a dead key symbol while not editing any notes. That one happens instantly anyway, you wouldn’t be able to carry out any other actions.

Something to test against is whether the board has been saved to a named file or not. I’ve noticed the auto-save system for “untitled” documents in macOS 14 (maybe 13 too?) is less reliable than it used to be. It used to be it would auto-save almost immediately and you wouldn’t lose anything in a crash—untitled windows would all come back the way you left them when relaunching. Now though, you’re lucky if it saved anything in the past 15 minutes. Whether slowness like that would cause instability when trying to close an unsaved window, I don’t know.

In none of my testing, neither the times with the hang nor those when it didn’t hang, had I saved the board. In each case, I clicked the red traffic-light with the intention of closing the board without saving.

I did notice something that seemed a little odd when I tried closing a window with a note open for edit: a different save dialogue came up without asking or giving the option to not save (or ‘delete’). When I cancelled that, then the normal save dialogue came up, with that button included.

This is on macOS 13 though, which might be different. I’ll have to try again next time I reboot to that partition, but something is definitely not right on 13, so that’s something to report anyway.

I’ve just tried again:

  1. Created a new board;
  2. Double clicked for a new note;
  3. Typed a few words;
  4. Cmd-W to close the window without leaving the note.

New hang, no ‘alternative “Save” dialog’, but the File menu has a grey overlay showing it’s open but no menu drops down.


In the screenshot, the “rainbow pizza” doesn’t appear (I need to work out how to make the cursor visible for such screenshots… I use for screenshots).

On a second attempt, I got the alternative Save dialog and when I cancelled the other normal first-time save dialog immediately came up, so I clicked “Delete”.

On a third attempt, new hang as on the first. I have a dump of the report for the third if that would add anything useful.

I licked re-open on the report and Scapple opened including the board with the note, but the text I had typed was gone, just the “New Note”.

1 Like

That latter part actually makes sense though; I’m pretty sure that saving does not commit until the note is closed, so the last thing it would have auto-saved is the creation of an empty note.

Definitely seems like it could all be related though, even without hanging on 13.x, and probably enough to go on toward fixing it.

Great. If I find anything more, I’ll report back.

Incidentally, these times I wasn’t including any dead-key combinations, so we can forget that. I’ve read you answer in the other thread.