Problem with setting the spell schecker language

I have my Windows 10 setup for “Nederlands” (Dutch) in all the applicable areas.
But I cannot get scrivener to spell check in Nederlands
I write both in Dutch (Nederlands) and English, sometimes in German, very often mainly Dutch with English sections.
I want to have the UI of Scrivener in English as this makes using help from the internet or referring to your manual easier.
I also tested with the UI in Nederlands, (knowing this would likely not help) and yes I restarted scrivener after setting the UI language.
I need to be able to switch between langauges, like I can in Libreoffice, Thunderbird and other packages. At least for the project as a whole.
Help help!
PS I now have the opposite problem with this topic. I write in English (I hope), but the spell checker assumes Dutch. I see no way to select English for the spell checker.

The spell checker language is set by downloading the correct dictionary and choosing it as the one you want to use.
Options->Corrections->Dictionary
If you’ve already done that, then I’m sorry, that’s all I can think of. Need a Dev, :mrgreen:

THANK YOU!
You made my day! And the rest of the year.