Problem with the format on thecompiled pdf

Hi there,

I wrote a play using the Stage Play UK Format. Everything looks good in the editor.

But once the play has been compiled for a pdf, some parts look good and some others don’t. For certain parts, suddenly, the character / dialogue format doesn’t apply anymore and a big part (containing character / dialogue) is in the same action scene format than the action scene format used for a sentence before.

I’ve tried deleting those parts and re-writing them again. Once again, I used the tab key and all (same as for the parts that look gook) to get the right format. In the editor: it looks perfect. I have an action scene, dialogues, action scene… Once compiled: the same parts as before have lost their format and it’s a big chunk with the action scene format that appears instead.

I’ve also tried choosing the “default” format before compiling.

The problem remains. Have you seen that before? Would you have any idea about how to fix this issue?
I’m lost…

Thanks a lot :slightly_smiling_face:

Hi.

I don’t know how to fix your issue, but one thing I would try is to compile to RTF and open this in LibreOffice.
If it looks good there, use LibreOffice to convert to PDF, and don’t compile to this format in Scrivener.

1 Like

Hi Vincent,

Thank you! I’ve just tried, the issues are still there in the .rtf doc.

Just in case: if I copy-paste the content on screen from the editor (ctrl +a) and then paste it in a .doc, the issues are gone, but other appears (the layout is a bit different etc.)

So I’ve started tying something: in the editor, instead of deleting and rewriting, I copy-pasted a previous action scene line, one that had no issue, over the one that had an issue (and then I modified its content).

Then I did the same for the character / dialogue line that followed. I compiled to pdf. Those two lines have no longer any issue! So the problem must be somewhere in the format (I can’t see it on the editor but it might be visible in the code).

It’s a lot of rewriting, and I don’t get why simply deleting and rewriting doesn’t work, I don’t understand why I have to copy-paste “healthy” parts, so it’s not really solved. But in case someone has got the same problem, at least you know you can do this. If this sounds a bit confusing, I can make a video to show what I did.

Have you tried compiling as-is ?

Could it be that the problem is in Compile? In the format you are exporting it, did you unclick the option for ‘overwrite text and notes format’ (in all sections)? If not, it’s possible that Scrivener is overwriting what you have on the editor to match the settings of your format, that would explain why you see it perfect on the editor and not in the compiled project.

Yes, that was my first try, the issues were there

It is unclicked indeed! I clicked and made a new try, the issue persists, this is so puzzling.