Problems compiling for final draft 8

I’ve written a treatment in Scrivener that I wanted to compile for Final Draft 8 so that I can complete the screenplay there.

Ideally it would “paste” into FD8 in “action” format, using the default courier font/spacing I use there. But when I do this, even when checking the box ‘use final draft screenplay elements’, it appears with the scrivener fonts/spacing.

I’d also been organizing my scene headings (INT. LOCATION - NIGHT) as the titles of my index cards and would love to not have to re-type all of them in final draft.

I didn’t use ‘screenplay mode’ to write the scrivener treatment.

Any thoughts, advice, workarounds appreciated.

  • Doug

What do you mean when you say you are trying to “paste” into FD8? You need to use Compile for it to work. But you also need to have used Scrivener’s screenplay format. That allows Scrivener to recognise the various different script elements (scene heading, action and so on). If Scrivener doesn’t know which script element is which, then it can’t include that information correctly in the FDX file and so Final Draft won’t be able to interpret it correctly. Final Draft isn’t like a regular word processor - in order to format the text correctly and to know where everything goes, it needs to know which element each piece of text is supposed to be.

So the only way to get all of this to work is to use scriptwriting mode, I’m afraid.

All the best,

Thanks, Keith, I am using compile. And when I open the compiled project in FD, it recognizes the text as if it were the script element “action” (as opposed to say, scene heading, character etc). This would be fine for me if the text would appear formatted according to my FD settings but it doesn’t (even when I check the scrivener box that invites me to ‘use default fd elements’). Is there a way to do this? And if your answer is the same, is there a way to convert my scrivener project into screenplay mode before compiling?

To be clear, I’m not looking to write the entire screenplay with scrivener in screenplay form. I’m using it to create a treatment where each index card or scene has a scene heading (INT. LOCATION - TIME) and a description of what happens in that scene in action. And then I want to work with that text within FD (and not overriding FD’s formatting settings) to format dialogue, transitions etc.


I believe FD defaults to “Action” when it can’t recognise the formatting, so this is why everything appears as action.

There are a couple of problems with your approach: the titles and synopses in index cards never become scene headings or action in FD. Instead, they become summary cards (FD supports titles and summaries for each scene, and this is what the index cards in Scrivener become).

However, if all your text is in the index cards and there is no text in the main text area, I wouldn’t expect there to be any text to look at in Final Draft, and yet you say there is some text but it isn’t formatted as you hoped. Could you please give me a more thorough description of what text you have where in your project, or possibly provide a screenshot, so that I can get a better idea?


Thank you for your patience. Sorry I got some of the jargon wrong. Meant to say documents, I suppose instead of index cards.

Here are some screenshots of an example:
This is how I set up the project:


This is how I compiled it:

This is what I got in FD:

This is what I want to get in FD after the compile…