Problems with New Beta 1.7

Thank-you for this new beta and all your hard work x

I downloaded it straight away, and have been trying to use it, but in a short space of time - an hour? - it has crashed on me five times.
Three times when I was trying to change the font settings, once when I was trying to select all and not quite got to changing the font, and once when I had just started it again and was trying to start typing . . but I will persevere!

I forgot to add - I am using Windows Vista 32

Same with me - crashed twice in 15 minutes. But can’t seem to replicate the crash. Went back in did what I was doing again and was fine.

So my caveat is - remember this is still a beta release!

I’m using windows XP

Some odd formatting issues popping up.

Ruler did not up at first in Show Text View. Aside from the tab markers on the left hand side that is… And all text was in a what appeared to be a 3in column. I tried moving the tab hoping this would fix the ruler and then the program crashed.

I restarted and all text was normal. But the ruler was still missing. I then messed around with CTRL-A (having read the post about it causing a crash) and suddenly the ruler returned, but the text went back to column. I CTRL-A’d again and the text now everything appears normal.

I’m also having problems with it crashing - 4 times in under an hour. Sometimes I’ve been copying text - once a whole paragraph and once 5 words. Another time I was just typing. I’m running Windows 7.

My problem when using Beta 1.7 for the first time is that all my margins went completely wonky. I’ve got right margins that decreased to 3 inches instead of 8 and I have been trying to fix it.

So far, I have been unsuccessful at changing the right margin. The ruler is gone for the most part and if I can get it to appear, it has tab marks every 1/2 inch. HELP!

Beta 1.7 keeps crashing on me whenever I try to change the margins or move from folder to folder. I am using Windows XP.

I uninstalled everything and re-downloaded beta 1.7 and I still have a problem with the margins. I have 23 folders in one manuscript and about ten of them have the proper margins and the rest don’t and I cannot fix it.

I lied. Every time I open up Scrivener, more folders get the new funky right margin that I cannot fix.

Okay, now after multiple crashes (thirty or more), the margin ruler in some folders is working again. But only if the text has the proper layout; not if the text is at a funky margin setting that is no where to be seen.

Okay, I’ve gotten the funky right margin a few times, and it changes back to normal if I change the zoom. Attached a picture of what I’m seeing. It’ll change to the funky right margin when I change documents. Zooming in, then back, or out then back will fix it.

Can’t get it to crash with the ctrl-A, although I did get it to crash once seeing what happened if I used the update. I haven’t been able to reproduce it since.

I did, however, get it to crash by clicking on documents in my binder in rapid succession. It’s a 100K word file I created out of lorem ipsem, though. I can reproduce it, but it takes awhile. (That is, it doesn’t immediately crash) To reproduce: randomly click on documents in the binder, change views, zooms, etc.) Attached that project file, as well.

ETA: the funky margin thing is showing up in real projects, as well, but it still goes away if you change zooms.
test|attachment (276 KB)

I do not know if this is a bug since I did not try this on the other versions.

When I am in corkboard view and press the corkboard view button (middle button), I get the text view. When I am in text view and press the text view (left hand button) button, the page goes blank.

When I am in the folder view (the right hand button) and press the right hand button, I get the text view.

Mea culpa if this is supposed to happen.

I’ve tried the zoom to fix the margin issue, and it doesn’t work. I can have the ruler on top show a 6" margin yet the text is at the 3" margin. I can’t fix it unless I go into corkboard view, then move to another folder, put that one in corkboard view, then move back to the original folder, then go to text view. Pain in the you know what to have to do all the time. I have gotten to the point of ignoring the ruler on top since I can do nothing to change it. Nothing works on the ruler no matter what I try.

I love that you’ve created this for Windows users. I did the trial version on my Mac, and I thought it rocked, but I basically hate my Mac (it’s slow and the keyboard is wonky), so I was excited to see this beta version.


First of all, I downloaded it on Tuesday, 2/22/11, and before it even started up it said that version would expire on 2/25, and then it crashed.

I tried to start the tutorial, and it crashed. I tried again, and this time it locked up my computer.

So I figured, wait until Friday, try the next one. Downloaded it a couple of hours ago. Could not uninstall 1.6–that is, it doesn’t seem to be there, but it’s still an option to select, as is “Uninstall 1.6.” There were no documents created in that version, so that couldn’t have been the problem. And when I select 1.6 from the start menu, nothing happens (well, the flashlight appears, but can’t find the program).

I did get through the tutorial. My version does not create PDF files, or rather, it creates PDF files that have errors in them. A couple of other things mentioned in the tutorial did not seem to exist.

I tried using the screenwriting version. All the icons are mislabeled. If I select “Screenplay” I get “Comic screenplay,” if I select “Comic screenplay” I get “BBC taped drama.” For some reason, it seemed more intuitive in the Mac version.

I eventually got the correct template, Screenplay, but as soon as I tried to select “Scene header” it crashed again, although without locking everything up.

It did save what I had already written, which was great, even though it was only about four words at that point.

(It would be really nice if it eventually would compile to Final Draft. I don’t suppose that will happen, though.)

Whenever I use a split screen and try to close one, I always close the wrong one. What happens is I click into the one I want to close, when I guess I should be clicking into the one I want to keep open. For some reason this seems backwards to me.

my 1.7 on XP is crashing when I hit the ‘check for update’ button

Just a little bug I noticed this morning. When I click on help>known bugs in beta 1.7 the web page isn’t recognised!

I’m brand new to Scrivener, and am loving the idea. I downloaded 1.7 last night and created a couple projects. When I opened one of them this morning, all my text shows up as black blocks–just in the main editing window, the notecards look fine. If I select it I see my words in white on a blue background, so they’re still there.

Clicking around some more, it appears to only be some of my pages that are doing this. Others are just fine.

I have been trying to fix the right hand margins. If I choose the corkboard view, then move away from the folder, then go back and choose the text view, the right hand margin is correct EXCEPT that the margin ruler still shows the 3 inch margin. I cannot move the markers. i can’t do anything to the ruler. And that is if it shows up at all. I can still work in scrivener but I have to remember to change to the corkboard view before moving away so that I have a proper looking text view when I come back.

Another thing, I understand this is a beta, is that when I move between folders multiple times, then try to edit the text in one folder, Scrivener crashes. This had been pretty consistent today. if I stay to one or two folders and go back and forth, not a problem. it’s only when I go through several folders.

Also, now when I open Scrivener, it always goes back to the save point that I had when Scrivener beta 1.7 was downloaded. No matter where I am in the manuscript, no matter which folder, when I save, exit, and reopen Scrivener, the cursor is at the folder I was at first when I first opened Scrivener beta 1.7.

I’ve tried zooming in and out and all that happens is that Scrivener crashes when i click on the text. I still have a problem with the margin unless I click on corkboard view then move to another folder then go back to the original and go to text view. The text then fixes itself but not the ruler on top.

I just keep adding. If I keep Scrivener open without working on anything, (just staring at the screen) long enough for the auto save to have worked a couple of times, when I go to edit, Scrivener crashes. This has happened several times now and I can replicate so I view it as an issue.


I also got the crashing bug when changing font sizes.

Generally it crashes when I have the main project selected on the left (I think the default name is “draft”) and then select text view. Then if I select the text of multiple text files within the window and try to change the font for them all it will crash. Sometimes I have to try changing the font a few times to kill it, but it’s pretty consistent overall.

I know this is only a beta, but I really am thrilled with Scrivener thus far. :slight_smile:

I’ve had the ruler issues others have mentioned. Seems that changing the zoom level fixes the issue.

It’s also been crashing somewhat frequently for me, though I’m not exactly sure why… Last time it happened when I clicked a different folder in the binder.

Ok, have to install the upgrade, have backed everything up -upgrade -everything gone - have done a system restore - so hope all my work is still there - but it won’t let me in to 1.6 where my work is, and I’m too afraid to try and upgarde again please help me -lots of work that is vital, and no way pf getting to it! I had this problem with one of the other upgrades - but backing up the work sorted it - this jut shows no work - says it is elsewhere on the pc.



It is highly recommended that a complete uninstall of beta 016 be undertaken after backing up any work that may exist in the Scrivener directory prior to install 017.

OK, freaking out a bit more now -I want to double check I have backed up - but I can’t as I have to upgarde - it wn’t let me do a thing - but if I uninstall - won’t everything just go???


Your projects should be untouched by the install/ uninstall process unless you’ve saved them in the directory you installed Scrivener to.