Problems with RC19 in-app updater?

I ran into some difficulty updating to RC19 from within Scrivener itself – the installer downloaded just fine, and closed Scrivener to update as per usual when prompted, but once Scrivener was closed the installer did not run. Thinking it might be an issue with my antivirus (per various other threads noting AV interference with the beta), I disabled my AV – the installer then ran as usual, but the updated Scrivener gave a Windows error when I tried to run it and refused to open at all.

Downloading and installing the new beta manually from the forum worked just fine, so this isn’t a ‘game-breaking’ bug, but I thought I ought to mention it since there have been noted troubles with the in-app updater before.

Agreed. See my earlier post on this and the solution I used.

Same here. After in-app update it gave me Windows error 0xc000007b, as though .NET framework got corrupted. I downloaded the installer and launched it, without uninstalling previous version, and it went well.

Downloading the x64 version and installing overtop existing didn’t work for me. Same error occurs.

Re-installed into a new Program Files directory worked for me.

Sometimes it works; if it doesn’t you have to uninstall it manually and reinstall it.

the 64-bit-installer from the website didn’t work for e either.
but the 32-bit-insaller. I got a warning, but then it worked nonetheless.

I have the same problem!!! My paper is due and it is stuck in Scrivener! This is a problem. I am in graduate school and the deadline looms!!! Please Please Please resolve this!

Uninstalling and Reinstalling worked!
Thank you for posting the solution. :slight_smile:

The autoupdate process has been fixed now as well.

The in-app installer worked fine for me. I’m running Win 10 Home 2004 version with all the updates (blah)

You, like me, probably ran the auto-updater after L&L sorted out the swapped files.

This is one of those occasions where being too lazy to get out of bed and go downstairs and boot Win saved me the hassle. :slight_smile: