Problems with Tables

Getting ready for NaNoWriMo and I am having some major problems with the tables in Scrivener. I have been fighting with them for days! And for the record, I have already tried:
Complete uninstall and reinstall of the newest beta
Complete new file

So here is what is happening:
I wanted a comprehensive 101 question character chart on my scrivener. In a table. The website I go the list off of did not have the list in a table format so I copied and pasted it into a word document to automatically place it in a table. I then copied THIS file into scrivener.
When I try and type in this file it lags SO bad that I cannot stand to write it in. The longer the sentence (or whatever I write without pausing) is, the longer it takes to actually post said sentence.
I figured something most have went wrong and started to make the table myself.
I put a small table in scrivener (10 lines, 2 columns) and copy and pasted all the questions from the first part of this sketch into my table.
It seemed to work fine, typing was no longer lagging.
When I went to a different page in my scrivener and then went back to my page with my new table, the table keeps adjusting itself. I wanted it at 50%/column, and it keeps changing it to ‘fixed 306pt’
Tried fixing the columns and when leaving that page and going back, it is again at 306pt.

Opened a brand new scrivener file and tried to just make my own table. Same problem with it resizing.

I don’t know what else to try. Any suggestions?

Testing and testing and testing.

Have narrowed down the MAIN problem.

My tables will not hold the shape I want them to hold. They automatically switch from percent to fixed when I leave the page they are on. The fixed holds the general shape of my table, but tends to make the columns bigger than I want them. (example, I have a table with percents as: 10,15,5,20,20,and 30 when I change pages, the fixed numbers change to: 61,91,30, 122, 122, 183)

This would be fine if it didn’t stretch out my page and force me to scroll to see the entire table.

This happens in a completely fresh project with the newest beta installed.

I would also really like to be able to post a table from Word into scrivener without the crazy lag problems. Or be able to convert text to table within scrivener, but the viewing of the tables is my main problem.

Lag issues we’ll definitely look into. For the percent problem, that’s an RTF encoding issue that we’re not going to be able to change just now. RTF is only able to deal with fixed-width, so although you can set the table to a percent while working with it in the editor, once it saves to disk it saves a fixed width. It picks the width off the percentage you gave it, however, so the print-size should end the same.

Although Lee may be able to look into modifying the RTF code in the future to add custom tags and see if there’s some way to work around this limitation, that’s a down-the-road sort of thing as it’s going to be a good chunk of work and may end up coming to nothing if it’s just not possible. We will add a bit about this into the documentation, however, to make what’s going on here clearer, since it’s not obvious why the table settings are switching behind your back.

Lag, though, like I said, sounds like something else entirely, so I’ll give a go at replicating this and will let Lee know. A few other users have been experiencing fairly general lag (probably due in large part to some of the optimization code Lee had to remove), but I gather you’re only seeing this when working in imported/copied tables?

Yes the lag I am experiencing is only when copy and pasting a table from Microsoft Word into scrivener.

And It isn’t that I have a problem with it changing from percent to fixed, but when it is on percent, as I change my screen size the table sizes changes, yes? When it changes to a fixed ratio it stretches out my table and my screen because it doesn’t take into account that I have the inspector open and viewable. When I hide the inspector, the tables display perfectly even when changed to a fixed ratio.

Does that make sense? I am awful at explaining things…


My problems with tables is that they do not maintain columns within a table.

Create a two table, two row column.
Merge the first column.
Looks good at first. I can work with the table.
Save it.
Exit Scrivener.
Go back in and view it.
The table keeps the first row with two columns.
The second row no longer has the second column.

I have uninstalled and reinstalled Scrivener (latest version).
I have tried:

copy/paste from Word (.doc)
import from Word (.doc)
manual creation of the table in Scrivener

What am I doing wrong?

Thanks for your help.

This is my problem as well! I have a very complicated series of event that have to be precisely timed, so I made myself a 3 column table with 25 rows. Save save save, backup, fine and dandy. When I opened it the next day, more than half of the table was GONE, essentially the entire lower right portion. No columns, no rows, and NO TEXT!!

I rebuilt it and thankfully printed it, because when I opened my project again just now the same thing had happened!

What’s going on? This is UNACCEPTABLE!

Ugh, sorry, don’t mean to yell, I’m just horrifically frustrated! Any help will be greatly appreciated!

I reported these bugs here, along with some other things. Any reply yet? :confused:

Sorry, guys, we’ve been a little shorthanded and swamped. I’ve reproduced this and filed a bug report for Lee. I’ll let you know if I come up with a workaround in any further testing.

Happy Christmas to everyone.

I am having exactly the same problem with disappearing cells in a simple 3 x 5 table. Using Version 1.2.5 30-day test. I recreated the table after the first time and rearranged the columns. It is has now happened a second time.

Birmingham Alabama USA

This has been partially fixed for the upcoming release. If you’d like to test it out, feel free to download and install the beta, available from the beta forum. Be sure to read the notes on the release.