Problems with upgrading to 2.3

Hello!
I was running Scrivener on a MacBook Air, with Lion 10.7.4, and tried to upgrade to Scrivener v. 2.3 but am now experiencing a serious problem in that I cannot open the program at all.

When I opened the DMG, I got to the screen where you drag the Scrivener icon into your Applications folder, and chose to Replace the former version of Scrivener.

Then I got the following error message:
“The operation can’t be completed because some items had to be skipped. For each item, choose File > Get Info, make sure “Locked” is deselected, and then check the Sharing & Permissions section. When you are sure the items are unlocked and not designated as Read Only or No Access, try again.”

Now, if I attempt to open an existing Scrivener file on my laptop or even open the program, I get this very large error message:

Process: Scrivener [25256]
Path: /Applications/Scrivener.app/Contents/MacOS/Scrivener
Identifier: Scrivener
Version: ??? (???)
Code Type: X86 (Native)
Parent Process: launchd [118]

Date/Time: 2012-06-28 12:44:49.131 -0400
OS Version: Mac OS X 10.7.4 (11E53)
Report Version: 9

Interval Since Last Report: 38259 sec
Crashes Since Last Report: 4
Per-App Crashes Since Last Report: 4
Anonymous UUID: EB25CC84-500D-4699-A387-7545A7AA82C6

Crashed Thread: 0

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: @executable_path/…/Frameworks/ScrAppKit.framework/Versions/A/ScrAppKit
Referenced from: /Applications/Scrivener.app/Contents/MacOS/Scrivener
Reason: image not found

Binary Images:
0x1000 - 0x2eeff9 +Scrivener (??? - ???) /Applications/Scrivener.app/Contents/MacOS/Scrivener
0x8feb1000 - 0x8fee3aa7 dyld (195.6 - ???) <3A866A34-4CDD-35A4-B26E-F145B05F3644> /usr/lib/dyld
0x98b21000 - 0x98b21fff com.apple.Cocoa (6.6 - ???) <30E6ABEE-B390-3C02-8C76-9C62F19FAA83> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa
0x9bf98000 - 0x9bf98fff com.apple.Carbon (153 - 153) /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon
0x9c0f8000 - 0x9c149ff9 com.apple.QuickLookFramework (3.2 - 500.16) <725FAE01-1597-38C7-841D-D9D83358921E> /System/Library/Frameworks/QuickLook.framework/Versions/A/QuickLook

Model: MacBookAir4,1, BootROM MBA41.0077.B0F, 2 processors, Intel Core i5, 1.6 GHz, 4 GB, SMC 1.74f1
Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In, 384 MB
Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1333 MHz, 0x80AD, 0x484D54333235533642465238432D48392020
Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1333 MHz, 0x80AD, 0x484D54333235533642465238432D48392020

PLEASE HELP! I need my Scrivener!
Best, Moira

Same problem here, probably same panic. Uninstalled Scrivener, reinstalled and now have 2.3 running fine. Bad moments, there, though.

Hi,

As Dogwood Fir has done, just re-download Scrivener from our main page:

literatureandlatte.com/scriv … atform=mac

Re-install and you should be good to go. What this means is that the automatic failed at some point because your computer didn’t give it permission to overwrite the necessary files for some reason. This happens to a handful of users every time (not through a fault of the installer, exactly, but just because of the way OS X permissions can be a little fussy). By re-installing from the site, you are just doing manually what the updater does automatically.

All the best,
Keith

Phew! Yes, that worked. I had to delete the old version completely, then install the download, and now it is working. Sorry for the panic but you know how it is when you want to write and there’s a technical obstacle in the way. Thank goodness for forums.

Glad you’re back up and running! And no need to apologise: by the standards of the good ship Scrivener forums, that was a very calm plea for help. :slight_smile: