Project does not have .scriv extension

I was just adding a step to make a copy of my GitHub-Pages Scrivener project to the GitHub project, so people could look at the file and (one likes to imagine) learn from it.

I noticed that unlike most of the Scrivener projects in my Dropbox/Apps/Scrivener folder, this one doesn’t have the .scriv extension.

Two questions: is this a problem? should I just go ahead and add the extension? how might this have happened?

(I have an unusual notion of two, I guess.)

The extension might just be hidden. To check…

  1. Select the file in Finder and then choose File > Get Info, or press Command I (that’s the letter I for Info)

  2. If necessary, click the triangle next to Name & Extension to expand the section

  3. To show / hide the filename extension, select or deselect “Hide extension"

Who ARE you people? Have you no lives? :slight_smile:


Yes it does seem to be there and hidden. I didn’t know some could be hidden and some not.

Thanks! :slight_smile:

Now I feel sad.

You’re welcome. There is an option in system preferences to show or hide all extensions. Apple has info on the link below about how the global setting impacts on different files…

Feel happy at having contact with another human, and helping them. :slight_smile:

Which has led me to another issue: I was going to use Ruby::FileUtils to copy the “file” over. As it is a directory, FileUtils.cp doesn’t want to do that.

I’ll try just using a copy command but I’m wondering what GitHub is going to think of this thing up on their site anyway.

I think I’ll try it manually …

I’m delighted, of course.

Know very little about GitHub, so I’ll just blink my eyes to show my confusion.