"Project is incompatible with this version of Scrivener"

I’ve been troubleshooting this issue for most of the afternoon but with no results so I thought I would finally - for the first time - turn it over to the Scrivener gurus. I’ve been using Scrivener for nearly two years now and I’ve been using both Windows and MAC Scrivener clients for over a year. I store my files on a fold on my Skydrive. Up until recently I have not had any issues moving between either platform.

Now, suddenly my Windows 8.1 PC is unable to open any of the projects on my Skydrive. Whenever I try, I receive the following message:

Project “Project Name” is incompatible with this version of Scrivener.

It also displays the path. I created a test project on windows and attempted to open and edit it on my MacBook which worked. The edits saved and I went back to Windows and was also able to open it and use it. But any other project prior to that, weather created in Windows or OSX is, will not open in Windows 8.1. I looked through the boards and couldn’t find any post with the same issue, so if I missed it then I apologize.

I was wondering if anyone else had run across this issue.

Both systems are completely up to date as are both versions of Scrivener and I’ve attempted an uninstall and reinstall of the clients. This is my first time using Scrivener on my Windows PC since the 8.1 update and I’m kind of leaning toward that as possibly being an issue but I wanted to run it by the boards first and see what you thought.

Any help would be greatly appreciated.

The same problem popped up for me tonight, though I don’t use a Mac–I’ve got Win 7 on one machine, 8.1 on another. Using Skydrive for main projects storage, and backups go to Google Drive on manual saves.

Win 7 seems fine.

8.1 duplicates the troubles mentioned, with some additional issues.

Not all projects are “not compatible.” Some open, but many files within them are untouchable. Error says:

Could not load document ‘doc name’
RTF Inspector could not read document from location: “file path…”

There’s a big instruction to backup, save and restart both Windows and Scrivener, and it winds up with the note that I won’t be able to modify the file until I restart.

When I create a new file in spite of the error message, it will only appear in the trash! What a terrible comment on the writing I haven’t even written! :slight_smile:

In addition, backups to Google Drive won’t work, either. I’m told I don’t have access to that location, yet a quick test doc in Word saves there fine.

Any clues will be appreciated!

There are a number of syncronization services that don’t do well with Scrivener’s project files. Skydrive may be one of them. Look in your .scriv folder and compare it to a known good project, such as a newly created tutorial project that is stored somewhere other than your skydrive folder. Most if not all of the non-numbered files in the tutorial should also be present in the projects you are having trouble with.

One thing might alleviates some future sync issues is to increase Scrivener’s auto-save interval to something like 10 seconds, so that you don’t bombard the sync server with rapid uploads. (see Tools->Options->General).

SkyDrive does appear to have been the source of the issue. I moved my files over to the Drop Box client on each platform and the problem has not presented itself since. It’s strange because before the Windows 8.1 update, synching worked fine between the two devices through SkyDrive. It is nice to have it working again, thanks everyone for the replies. Hopefully those issues can be resolved by whatever Microsoft entity has the power to do so, I much prefer it over Drop Box.

Thanks again. :smiley:

Glad it worked out for you.

From what I’ve dug up, a big issue with 8.1 vs. 8 is that Skydrive 8.1 no longer automatically syncs your files. You have to right click folders or individual files and TELL it to make them available offline, there is no indicator of upload/download issues, and it’s all so “convenient” that it screws everything up without telling you.

I believe the time lapse between attempting to open a project and having Windows download it (while I thought it was already local) threw something into total wonky-land. Only a handful of my projects on Skydrive work anymore under any circumstance. I even copied them to a Win 7 machine and tried to open 'em. Nothing. Nothing! And I find that multiple scrivx files are being saved in the scriv folders when I try, which is plain weird.

Lucky for my projects, I had my systems set to backup 3 deep on Google Drive. Those projects work, so I’m going through them and re-saving each one locally until I migrate it all to Google. I’ve only lost a tiny bit of work–so no disaster, just a time-wasting, stressful pain in the butt.

Thanks for the upgrade, Microsoft. Every new improvement makes me plan more on getting a Mac.

PS: Also, the Skydrive “Fetch” feature is now history… I don’t get it. That was an incredible feature, and they dumped it in the fix.

Good luck and beware to all reading this! :slight_smile:

Unfortunately, I need to warn you away from keeping live projects on Google Drive as well. We’ve had a lot of problem reports with that GD; it just doesn’t seem to handle Scrivener’s package format very well. Saving backups there is great, and I do recommend that.

Have you checked Scrivener’s automatic backups for recovering any of your lost work? In Tools > Options, choose the Backup tab and from there you can open the folder where your backups are stored. You may not have any with that lost work, but if you didn’t previously check it’s worth looking! And I’m not as familiar with SkyDrive, but if it has any kind of backup or versioning system, you may be able to retrieve older copies of files from there as well.

Thanks also everyone for the heads upon the SkyDrive 8.1 “improvements”. I’ve added an advisory to the KB article on synchronising projects to warn anyone else who may be seeing this sort of thing.

So I’m about to start a project which will need to shared between Scirv on Windows and Mac- what is the recommended sync mechnanism - dropbox?

I’m collaborating on a project with a friend who’s a Windows user. I’ve actually set up a Cubby https://www.cubby.com/ for the purpose — thanks for the heads-up on Cubby to Dr Nom. I also use Dropbox, but Cubby gives you 5GB space free, as opposed to Dropbox’s 2GB. I’ve been using Dropbox for about three years, Cubby for less than one.

Functionally, they both seem equally stable and reliable.

Cubby (on the Mac) has the very minimal disadvantage that if you use the menu to open a Cubby you have to open the app from the menu and then choose in the window that appears, whereas Dropbox opens it’s folder directly. I suppose the reason for this is that you can make any folder/directory on your hard disk a Cubby, so this keeps the Cubby menu short.

On the other hand, Cubby’s ability to designate any folder/directory as a Cubby — just like SpiderOak does — is an advantage. I haven’t bothered to see if recent upgrades of Dropbox also permit that.

There’s another interesting thing I’ve found with Cubby, on the Mac side, which to me is a huge benefit. When my collaborator is working on the project, Growl on the Mac sends up an alert each time any file in the Cubby is changed, and when she exits Scrivener or closes the project, the ‘user.loc’ file is dumped in my trash. I haven’t tested what happpens with Dropbox, but I don’t think so. I think if it did, someone would have mentioned it already. Anyway, this means I know when she’s working on the project, so I don’t try to open it myself until there is a long pause with no notifications and I find the ‘user.lock’ file in the trash. I empty my trash frequently, so it’s a good check. I don’t know if there’s a similar notification system like Growl available for Windows.

I am actually using Crossover (Wine) to edit the project with the Windows version, as it involves Chinese. The only problems seem to be: (1) my missing features that are there in the Mac version, but not yet available in Windows; (2) my complete unfamiliarity with the Windows interface and its menu/shortcut conventions ("Why the hell won’t it paste? … Oh, I should be using Ctrl-v, not Cmd-v”, etc. :slight_smile: ); and (3) most importantly, my occasional forgetting that I have to use the menubar in the Scrivener window, rather than the Mac menubar, which says ‘Scrivener’ but which only allows me to quit Scrivener, but is essentially a force quit, thereby causing loss of work.


I’ve got projects on a Win 7 machine and just got a Surface Pro 2 (Win 8.1). I set up a SkyDrive folder on the Win 7 machine, and I tried to open them on the Surface, but I’m getting this “incompatible” message with the few projects I tried to open.

However, I’ve also noticed a broader issue. My folders from the Win 7 machine are all marked Read Only. The issue appears in both SkyDrive and DropBox. When I try to even edit Word documents on my Windows 8.1 machine, they open as Read Only. I can edit these documents on my Android phone in DropBox. When I try to change the folder properties, it looks like the change is being made (get a status bar, etc.), but the change doesn’t stick.

I’ve tried setting attrib in MS-Dos command window. I’ve tried turning off UAC. (See this article: http://itexpertvoice.com/home/fixing-the-windows-7-read-only-folder-blues/).

So, I’m wondering if this is related to the ongoing problems with windows file permissions.

Whatever the cause, I’d love to get a fix to this ASAP. I bought the Surface Pro largely because it was the only Tablet that I could run Scrivener on. I can’t really do that yet, so that’s a major problem for me.

I’m a programmer by day, and I’m happy to beta test a solution or be an active troubleshooting partner.



Here’s the workaround that worked for me. I connected to SkyDrive with my Surface Pro 2, then copied all files/folders in the SkyDrive to a USB flash drive. I received a warning that all the attributes of the files could not be copied (which is what I was hoping for), and I proceeded with the copy.

I made another backup of the SkyDrive files to my Windows 7 laptop, just to be sure. Then I deleted the files in SkyDrive (via the Surface). Then I copied the files from the flash drive to the SkyDrive folder, also via the Surface. (I tried deleting and copying files from the flash drive via the laptop first, but the scrive=ner projects couldn’t be opened on the Surface).

I’m now able to open my projects from both my laptop and my Surface. Hopefully the nest release of Scrivener for windows will come up with a programatic solution to the file attributes issue. In the meantime, please post to the forum to indicate if this workaround resolved the issue for you or not.