Project not opening

I’m having a problem where the Dropbox project won’t open. I click on it, it looks like it’s trying to open and then goes right back to the first screen. Nothing pops up, or anything. It started after I synced it and it said there was a conflict but when I looked at the conflict folders there wasn’t a new one. It worked fine that time but when I shut it down and opened it later it wouldn’t open my file.

I tried duplicating the project, the duplicate project does the same thing.
I tried re downloading the app and when I tried to sync it to Dropbox a pop up came up saying it needs to be connected to the internet and requires so much space and give me the option to sync anyway. I did and it did but it still won’t open. I’m obviously connected to the LTE or I wouldn’t be able to be on this forum and I deleted apps to have more room and everything but it still won’t open.

I edited it on my windows version and tried resyncing it and it’s working fine now on both wifi and satellite internet. So I have no idea what happened