Project Search "Whole Word" does not seem to be working

When I enter a word in the search field (say for instance “fit”), and I select “Whole Word”, the results show words containing the search string (“fit”). I have tried every option but none of them return only those matches that are the word “fit” itself (and not "fit"ness or “fit"ting or sof"fit” for instance).

Please don’t tell me to surround the string with space chars as this doesn’t work if the word isn’t surrounded by space chars (as in, it is at the beginning of a bracketed phrase or ends with a comma, a period, a bracket, a slash etc.

(That’s Windows. So I guess the result you expect is what it should indeed be.)

Yep, but on Mac a “whole word” search for “fit” returns “fitness” and “fitting” and “fitted” etc.

Meanwhile, you could probably work around it with the right RegEx.

I’ve tried regEx. I am sure that Scrivener’s search options end up warping the user’s provided string in regEx expressions. So no, the regEx expression doesn’t work. Perhaps MacOS is demanding a new regEx handshake that this version of Scrivener isn’t yet passing.

PS: I am using Scrivener 3.3.6 (16305) on running MacOS Sonoma 14.2.1 on a 2018 15 inch Intel MacBook Pro with 16gb RAM.

RegEx does it properly on the Mac. Maybe you have the wrong search string.

1 Like