Project Searches -- Long, short; crossed ...

Mondays of sorts, ‘today’, are my day to work on, rather than with, Scrivener.

Just a couple of days ago (ie, two), I began getting a dialogue box when Scrivener opened – usually two projects – which said that the ‘indexes were not fully loaded *, that my first search might be slow, that it might be due non-standard characters ^’. (These were the first times I’d gotten the box.)

*Which tells me that indices are in fact saved when S. closes and are brought back upon its next opening: Good.
^Is there any guidance for what might be troublesome ‘non-standard’ characters?

If I start S. by clicking on the *.scrivx file for my usual core/principle project, S. and the project open normally.
However, opening the second project, Stack (via S.'s File menu, Recent Projects), I get the box: And when I take its Save/Reindex advice – takes about 25 minutes – it doesn’t seem to ‘take’; I got the box every subsequent time I open Stack.

So today, I opened my principle project by its scrivx, then opened Stack (via S.): Got the box as ‘expected’. This time however, I canceled/dismissed the box and simply began working with Stack, adding document items, etc: When I did do its first Project Search (PS), it responded more quickly than usual – in a couple, three minutes – and seemingly fully despite the box’s warning. :smiley:
And subsequent PSs work very quickly. (As Ioa has described them.)

Happily, I worked with both projects open: Ctrl-Alt-n’g in Stack to open new items; getting blank editor spaces; copy/text-pasting text from external PDF files.
:arrow_right: And then about a third/half the time C/A/n began opening new items with text in them, not blank – text from the other project!
Of course :open_mouth:

When I closed the other (‘principle’) project, the condition continued in Stack – From unpurged memory? An addressing issue?
(When I generated Stack about a week ago, it was as a blank project: It has no ‘user’ templates and no Options changes.)

(Yes, as I understand the architecture ought to be, the files for the two projects are in their own ‘scriv’ Files folder, and a Windows Explorer search for the inserted text in Stack’s new items, those then Trashed/Emptied from Stack, found the text only in the principle project’s … Files\Docs.)

Deleting the purloined text when necessary, I completed my ‘new item’ insertion tasks in Stack, then Exited Scrivener.
I restarted S. (Stack), got no box (remember, I had dismissed the box in the earlier S. session);
I then opened my principle project via File/Recent – All of Scrivener shutdown, about my usual long-delayed time that the second project’s window would have opened; the apparent second-project window flashed just before the shutdown. (I’ve posted about the rare spontaneous shutdowns before; they were more common during this troubleshooting.)

My ‘recovery’ Stack-alone restart via its *.scrivx came up quickly, again without the box.
I closed Stack from File/Close, then scrivx-opened the other project in this testing, my ‘principle’ one:
Ctrl-Alt-n worked properly, producing new items, which was not surprising, I’ve not had either the box or the inappropriate-text issue with the principle project;
Trying to open Stack from the principle’s File/Recent … shutdown. :cry:

Throughout, I restarted Windows (7) as seemed appropriate.

Not that I expect them to have any direct effect, I’ve stopped the ‘prior session project load’ (conceivable?) for now and the ‘closing backup’ (not so). Backups are still automated.

I have reinstalled 1.9.7 and Windows was shutdown overnight:
I opened S. and then the principle project;
With the principle project Scrivener window open, I opened Stack.
The text borrowing continues in Stack, beginning after eight Ctrl-Alt-n, occurring regularly thence.
(The box has not reappeared and so far, no spontaneous S. shutdowns.)

I know I’ve asked for cross-project searches, but I really wasn’t thinking of this kind of linkage … :wink:

If I get a mind and gumption to, I’ll define another new project and load it as I did Stack, click/drag, but will that bring across some linkage or pollution? I don’t know … .

But for now, this ‘Monday’ is done.


The principle project’s search.indexes file is 37 KB;
Stack’s, with about a 10% larger fileset, 146 KB.