Project too big for being backed up (on Windows 11)?

I’m new in this forum, but I’m using Scrivener from years now. Lately I switch and buy the new Scrivener 3 for windows and start using it with my personal project that I’m doing many years now. To be on the safe side I configured Scrivener for backing up my work each time I close the program. This works perfectly, and safe me many times. My project grows up and now it “weight” more than 600 mb. Few days ago I started to noticed that my backups are not done. I got an error that Scrivener “Cannot create temporary copy for backup” in the \Users<username>\AppData\Localt\Temp<hash><projectname>. Smaller project can do the backup without any issues. There is plenty of free space on disk (more than 700GB). I’m able to create folders and files in the directory that is mentioned in the error message. I also found some older directories that Scrivener tried to create. Some of the are empty, but few contained the part of the project files, but not all. Unfortunately I could not found any logs in Scrivener folder to check what is going on there.
Does this mean, that the project become too big for Scrivener to handle backups for it? I can zip the directory manually, but its not ideal solution. Automatic backup was great and it would be great as well to have it back again :slight_smile:
Btw. I upgrade from Windows 10 to Windows 11. Might this be the issue? I read that Scrivener 3 doesn’t have much problems on Windows 11.

Perhaps make a new backup folder location, e.g. \Users<username>\Backups\Scrivener\ and repoint Scrivener there.

If works, delete any old backup zips in the previous location.

It doesn’t change anything, because Scrivener is preparing backup file in this Temp folder on C: drive before copy it to the configured path. I changed this path many times to different drives but error remains the same and its about making backup on temporary location that is in C: drive.

Interesting. I didn’t know that backups pre-built in a temp folder. My only remaining suggestion is to duplicate the project and with the duplicate, remove and remove from trash the Research files (which I’m guessing is the bulk of the huge size of the project). See if a backup can be made with a significantly reduced project size…would test the question of “too big”.

Indeed, 600 mb is pretty big. Must have to wait a long time each time an automatic backup is made. If possible, you might find value in reducing stuff that really doesn’t value to be inside this writing tool. Just a thought.

Thanks for your reply.
It might be a bit complicated because I have lots of pictures inside the project that are part of it :slight_smile: Maybe I misuse Scrivener a bit, I don’t know. Till now it worked perfectly, thats why I decided to buy Windows 3 version when beta ended. I bought previous version as well and use it before I go to the beta.
I rather hoped for other solution :slight_smile: especially that I don’t personally believe that size matters in this problem. It started suddenly when the project was that big from meny months before. I did not add anything really big, because I resign from adding more pictures to the project years ago to not make it as big. Maybe I will remove pictures but this would be last resort for me. In my opinion it should not be a big problem for the computer to make a backup from even bigger folder. I can easily do this backup making a zip from the project folder. I’m not sure if this starts after I upgraded to the version After that it was next upgrade to but it doesn’t help for this issue.

Neither do I, but have no other idea for you. Hunch something to do with Windows. Others may know.

When I embedd pictures in a project, I tend to go to the effort of shrinking them to a size appropriate to the output target. Many times picture originals are orders of magnitude bigger than needed for ebook or paper display. I also put them in the Research folder and link into the document. This means I can replace pictures with different versions (content or shrinked) easily if necessary. Just what I do.

Hi walth,

Just to be 100% clear, are you saying these problems began after the Windows 11 upgrade?

I’ve no experience with Windows 11, so I’m absolutely winging it here, but it sounds to me like a problem with permissions (and not lack of storage space).

Some things to try:

  • Temporarily turn off your antivirus software and see if that makes a difference. If it does, whitelist Scrivener in your AV.
  • Uninstall and reinstall Scrivener (see uninstall/reinstall tips in this post). This is the nuclear option, but it might help reset permissions in the temp folder.

There are a few Windows gurus who hang out here, so hopefully one of them will chime in with more educated advice. :exploding_head:


1 Like

Definitely this is a great idea, and I think I use it in my project already, but I will revisit this as well.

I spot this issue after I upgrade, but to be honest sometimes I had my Scrivener project open for many days and did not backup it regularly. Sometimes I skip backup, and the error is showing when the backup progress bar is reaching 50% sharp. I really don’t know if this is an issue with Windows 11 or Scrivener 3.1.
If this issue would be because of lack of permissions to default Temp folder in Windows then I would not find any folders and files created in this folder during the creation of the backup. When monitoring the Temp folder when backup is in progress I can see that folders are created and sometimes subfolders with partially backed up project inside.

Antivirus is not messing up with this, but thanks for this idea. I tried and doesn’t change anything unfortunately.

Maybe I will do this, but to be honest I will switch to Linux and Wine instead as this Windows 10/11 is not the best OS I use… But I really curious what is causing this issue, so I really want to explain this :slight_smile:

Perhaps before jumping into this complexity (and I appreciate you like Linux, as do I) … as you are surely familiar with permissions, take a look at the permissions Windows has granted to the temp folder(s) to see if any clues. Just a thought.

Permissions are fine there. But I think I found where the issue was.
Because this project is very personal I use NordLocker to have it encrypted when going to the cloud. After I copy the project from the NordLocker safe into a regular disk space I was able to do the proper backup of the project. I don’t know why this issue starts lately. Maybe Windows 11 change something with tmp folder and maybe NordLocker, that worked perfectly on Windows 10 suddenly stopped on Windows 11? There is nothing in Windows Even Logs that could bring any additional data, so I think that mix of those two - Windows 11 and NordLocker - are not the best pair to use together with Scrivener :slight_smile:

Thanks for your help :bowing_man:

like peeling onions! :wink:

glad it is worked out. maybe not put such sensitive stuff in cloud where you feel need to add this complexity. protect with appropriate measures that does not interfere with Scrivener on local disk with encrypted backups into an internet service. best of both worlds.

1 Like

Yes :slight_smile: This layer was so natural for me that I didn’t think of it at all. Another point for switching back to Linux again.

Yes, well this is not a regular cloud, but my private cloud. But still its on someone else’s servers so, I wanted to have this encrypted but in the way transparent for me. Worked perfectly for long time and after upgrade it stopped. I preferred to have local backups stored on another encrypted disk connected to the laptop. Rest was on cloud in case something happened with the laptop and I lost it or it will be broken. This setup gave me great security and flexibility at once. I’m tempted to install Linux, but getting this flexibility and security there might be hard.

Windows 11 or an antivirus program may not like Nordlocker.

As to the original problem, I wonder if somehow that configuration was blocking your attempt to use the temp folder for security reasons? If the project is located in an encrypted vault, you would then only want its backups and other manifestations of it to also be encrypted, and writing to the global C: temp folder area is less secure. I don’t know by what mechanism it would be able to stop a program from doing that however, and I wonder if other tasks would be disrupted that make use of temp folders, like compiling to ePub (which requires assembling dozens of component files before zipping them up into an “.epub”).

It may be easier than you think. I do outsource cloud storage, using the Tresorit, which has an emphasis in secure & private storage, and the client for it works well (maybe even a bit better than the Mac client to be honest). It has a good mix of features for what I need, providing custom sync locations rather than one big blob folder that you have to put stuff into, non-synced storage for one-way safety, and of course selective syncing within sync areas is handled in an efficient way. It also can mount the entire share as a network file system for direct access with system tools at a reduce speed—which is nice if you store a lot more than you sync. But most open source personal cloud setups are going to be Linux-friendly as well.

The rest you refer to is quite simple to set up. The system from the boot image on down is encrypted, and my external backup drives are all as well. A simple rsync incremental setup is all I need for that.

Everything on my laptop is encrypted. There is no drive that is not encrypted at rest (when system is off), so I think it’s not big deal if program is temporary using a temp folder, especially that everything from this folder will be purged after that. But even if something remains there is not a big problem from my perspective, because to use it someone needs to mange to crack my disk password and then my user password (of course if disks will remains in the laptop and run under the “original” Windows OS I using). I use my “private cloud” because I have a shell account on some BSD based cloud where I can install whatever I want (from WWW server perspective not from BSD perspective). I decided to install Nextcloud there, but did not want to encrypt everything as I have bad experience with previous Nextcloud/Owncloud encryption so I think a perfect solution woul be to use NordLocker. This setup will not allow to send unencrypted files into the cloud, and also it is giving me a folder, that is encrypted on my local drive. Till you log in to the NordLocker you will not get decrypted files (which is not entirely true because NordLocker must decrypt it before you can use it, but the moment you logout from NordLocker is the moment when all decrypted files will disappear and your decrypted files will not be synced at all).

This is interesting solution and I will think about it. Thanks for the link.
But still, I have a good shell server on my disposal where I have my personal email and I can also use it as a file server and its rather cheap :wink: The cons are that I need to administer it in some degree, so its not as easy as this what you propose. I also have another private cloud server under my desk, but its entirely local, and there is no access from the internet to it. I use it more like a kind-of-a-online-backup for ALL my files (when I’m on my local network).

Yes, exact same setup I have now, I also had when I was using Linux (without NordLocker because it’s new product and also they don’t have Linux version). For the rsync part I rather want to avoid additional programs involved in this process, I prefer to have it as easy as possible. Of course I can automate rsync somehow (cron for example), but this is additional step that could go wrong and I can missed it. Even though I know how to write a shell scripts and so on, this is something that could be easily broken without notice. Sending backups of the project automatically when I close Scrivener was great from my perspective, because it was automated, under one program I already using and when something goes wrong I got noticed and could start looking what is wrong. Remember I’m talking about this Scrivener project setup only not everything I have on my laptop.

Once again, thanks everyone for helping me with this issue :slight_smile: I’m closer to start with Linux again then yesterday :wink: