Prologues and auto-numbering chapters

Hello. First post. :smiley:

I have my document set up so that the chapters auto-number on compile (with no headings). I have a prologue before chapter 1. This throws off the numbering so that chapter 1 is compiled with ‘chapter 2’ at the top - the compiler assumes the prologue is chapter 1, so everything is off by 1.

Is there anyway to get the compiler to ignore the prologue and start auto-numbering at the chapter after the prologue?

I have set the prologue chapter to ‘as is’ and then the numbers start correctly, but doing that means I lose all the formatting and the prologue is formatted differently to the other chapters.

Any help would be greatly appreciated.

Yes, you can usually do this without too much hassle, but it’s difficult to recommend a precise course of action for you without knowing what your binder outline is set up like. What is a “chapter” for example, in your outline?

You may be able to figure this out though by taking a close look at the Formatting compile option pane, and maybe consulting the documentation on it, to learn how you can assign different formats to different levels (amount of indent in the Binder) of items, as well as different types. Here is an example outline structure:

The thing to note here is that text files are on two different levels of indent. That means you can treat this “Level 1” file type with a title, while the “Level 2+” text files can go on acting as scenes (and of course, the folders act as chapters). That’s just one example of course.

Another case, you could always introduce a little artificial depth (for example, if you have 30 files in a flat list with the prologue among them) by indenting the actual chapters into a folder that is set to not be included in compile. It won’t appear in the output at all, but it will still bump these chapter files up to Level 2, where you can add numbering to the prefix.

Amber, thanks so much for your post. I used what you wrote to help me figure out how to get the chapter titles / numbers correct. I now understand how the ‘levels’ pane works in the compile dialogue.

Thanks so much. :smiley: