Proper name is underlined in red,

a name is underlined in red. e.g. Brodbeck. How to get the spelling recognized? Learn spelling not an option that is available.

Learn spelling should be available. What version of Scrivener do you have and with which version of Mac OS?

I have the latest Scriv and the latest OS

Does spellchecking work as expected in TextEdit? Mac Scrivener relies on the Mac OS spelling tools.

Yes. But not all proper names have the ‘learn spelling’ option

I get Look Up and Translate as the options

Hmm. Those are the options you’ll see if something is recognized as a correctly spelled word, but in that case it shouldn’t be underlined.

One way to work around the issue is to add names relevant to your project to the project autocomplete list, which you’ll find in the Project → Project Settings pane.

1 Like

okay, thanks, I’ll try that. It happens frequently

That didn’t fix it. I put the spelling in as you suggested but nothing changed. Should I go back and retype?

No, I retyped the name but it is still underlined in red

I’ve been seeing this issue as well. Some red-underlined words have the option to “learn” the word, while others only have the look up and translate options. I’m also on the latest of both (Scriv 3.3.6 and Mac 14.4)

The spell check contextual menu has been a bit buggy for a few macOS updates now. It not recognising that you right-clicked on a misspelled word, and adding the spell check functions to the menu, is something you may see from time to time, and will find other threads about it here on the forum. We’ve done what we can to make it more reliable, so at this point what you are seeing is originating from beyond Scrivener’s code.

If it happens, switch to using the Edit ▸ Spelling & Grammar ▸ Show Spelling & Grammar floating panel. That should always work.