Pulling hair out

Hi everyone,

I downloaded the demo for the Mac yesterday and I feel weird asking this but I’m having an issue that is driving me crazy.

I created a style called “Body” it’s just TNR 12pt but ever time I hit the enter button to do a paragraph the page style returns to “No Style” is there a way to make my “Body” style default?

I love the program proboly going to buy it


Stop wanting one. :see_no_evil:

You’re probably used to it from word processors, but Scrivener works a bit different. Best practice would be to set the editor font in the preferences or projects preferences and only style parts of the text that differ from that formatting.

Please check out the interactive tutorial (via the Help menu), it gives a good introduction to Scrivener’s philosophy.


While I do strongly second @November_Sierra’s advice it might be you forgot to set Next Style in “Body” to This Style.

1 Like

Hello and welcome. Your problem comes from creating a “Body” style! When you come to compiling, “No Style” will compile as Body/Normal style. Only use styles for paragraphs that deviate from the normal, like headings, block quotes, captions etc. By setting up a Body style you are giving yourself headaches further down the line.

But, when you do set up a style, like Block Quote for instance, you need to look at the bottom of the dialog, where you choose the style for the next paragraph; it is “No Style” by default.

HTH :slight_smile:



Instead of setting a body style, you’ll want to change your default font formatting.

You may also want to check these sections of the Scrivener manual out (you can find it under the Help menu):
§17.1 “Think Different” talks about how Scrivener differs from standard word processors in regards to styles and text formatting.
§B.3.2 “Formatting” goes over the Formatting options in the Settings menu.

1 Like

Or, in my case, structured markup systems. I hate the omission of a default named style in Scrivener; it goes against every good practice developed from structured markup (SGML for me) and reverts to procedural markup which leads to errors.

It’s not omitted, you can use a “body” style if you want to. It is just not recommended because it is simpler not to.

So HTML is bad practice?

Can you elaborate?


Exactly the opposite; it has structural markup. Poorly designed but structural none-the-less.

Clicking on italic when the structural element is Latin phrase or Linean species classifiaction.

There are two things I would say to that:

  1. As @suavito already noted, you are free to go wall-to-wall styles if you want. It’s just not the typical way and won’t work neatly by default with the stock compile formats that expect to be able to reformat unstyled text. That said, you probably aren’t using stock formats much, if you’re big on styles, since you’ve probably noticed none of them use any styles in the Layouts, even for headings!
  2. And that leads to the second point: even if you do leave body text unstyled in the writing environment, you can quite easily apply a formal style during compile, by having the layouts that handle text override formatting, and then apply a style of whatever name you need to the main text.

For myself, as one who uses Markdown, this has never been a big problem for me since body text in Markdown doesn’t need any special markup or treatment. It’s just text that starts at the beginning of the line with empty lines around it, by and large. For me that comes out semantic in any format that respects the notion. I would say that to a degree Scrivener kind of holds with that same philosophy: that paragraph text isn’t marked in a special way—it is mainly defined by not being anything else.

Thank you everyone for the feedback.

1 Like