Punctuation check missing commas

Hi all. When I use the “Check grammar with spelling” option in the editor it’s missing commas all over the place. I know I’m not getting them all right. In fact, when I move it to Word, the errors show up immediately. It’s catching spelling errors, but not punctuation. What am I doing wrong? I really don’t want to use an outside editing program. Going back and forth is too tedious.

Hi dcharlievine, and welcome to the forum.

It’s possible that a mismatch between your macOS settings–which provide the spelling and grammar-check tools–and Scrivener could be a factor in the behavior you’re seeing.

Whenever questions about spelling and grammar checks come up on a Mac,my first recommendation is that users review that they have spellcheck enabled via Scrivener > Preferences/Settings > Corrections and have ticked the Correct spelling errors as you type box.

Next, let’s also confirm that spellcheck is enabled on your Mac via System Preferences > Keyboard > Text and ticking the Correct spelling automatically box. That’s the path on Macs using macOS 12 Monterey or older.

For macOS 13 Ventura or macOS 14 Sonoma, searching for “spell” will likely get you to the settings more quickly.

Is Scrivener’s Edit > Spelling and Grammar > Check Spelling While Typing option selected? Since it has Command+/ (⌘+/) as a keyboard command, I’ve found that accidentally toggling that command on and off is easy to do.