Putting ToC in the back of the book

I’ve been searching in the forums for this and couldn’t find anything that helped.

I’m writing a Kindle book, and I want my Table of Contents in the back. I’ve tried creating a document called “Table of Contents,” but without luck.

I’ve also tried putting in <$toc> in that document, but I suspect I’m doing this completely wrong. The end result is an empty page with the title, “Table of Contents”

Any ideas?


If you want Scrivener to use that document as the table of contents, the name of the document must match the name set in the “Layout” pane of Compile:

That setting tells Scrivener to use the document with that title as the table of contents page; if it can’t find a document with that title, then it will create its own. That document can contain your own, custom table of contents using Scrivener links, or it can contain only the tag “<$toc>”, in which case Scrivener will generate its automatic table of contents and put it there. That tag must be the only thing in the document, though - anything else in the document, even empty space, and it won’t work. Also make sure that the document does not get joined to any other documents - make sure it has a page break before and after it.

Hope that helps.

All the best,

Thanks for the help, Keith!

This is exactly what I’ve done.

I’ve created a document called “Table of Contents” and I’ve set that title in the settings before compiling.

When I just use this, the result is a blank page with the title “Table of Contents”

I also tried <$toc> without anything else on the page, and after compiling the Table of Contents document outputs “<$toc>” so it doesn’t seem to be getting it.

I made sure there was a page break before and after as well.

Try exporting to PDF to double-check that the page really does have nothing on it except for <$toc> - remember it can’t have a title on it or anything either. (Try ticking “Compile As-Is” if it does.)

All the best,

Compiling as is did the trick.

It didn’t work when I compiled to PDF though. When I compiled to .mobi it worked. Is this normal?

<$toc> only works with e-books - I suggested compiling PDF purely to check that the <$toc> tag was the only thing on the page. Glad you got it sorted.

Understood. Thanks a bunch for the help, Keith!