Questions about compiling

I have two questions about compiling:

First question:

My current manuscript is split into 3 parts, which then contain chapters. This is achieved with folders, for example:

Manuscript > Part one > (chapters)

I would like this to be reflected when I compile to a PDF, with the “parts” sitting on a solitary page. Can anyone advise the best way to achieve this in the Compile options?

Second question:

Section breaks are added during compile with each sub-document inside a chapter folder with a “#”. I’d like to increase the spacing around the ‘#’ - an extra line either side of the symbol. Is this possible?

Both doable! You’ll need to expand the compiler so that you can see all your options–click the disclosure button to the right of the “format as” dropdown menu and your compile pane should reveal a lot of tweakable settings.

On the first pane, “content,” go through to all your part folders and check the box for “page break before” to set them off on their own. If you want “Part One” as text alone on a page, with the chapters starting the following page, also check the box for the next document on the list (presumably your “chapter” folder).

You can modify the section breaks in the “separators” section of the compile pane. Be sure to note which type of documents you’re separating (folder followed by file? folder from folder?) since you get a lot of options. There’s text explanation for each, so just check carefully for the “inserted before an x following a y” print. Then, to insert the extra line, hold the option key while hitting enter. (Note that the text field only shows one line, so you’ll have to use the arrow keys to see all that you’ve added–the “opt-return” may look like it wiped your hash marks entirely, because all you can see is the empty line.)

Thank you! Really appreciate the time taken to write such a specific response :slight_smile: I will try this and report back.

Also, be sure to take a look at the “Novel (with Parts)” template to see how you can set up a project to have parts and chapters - that template uses the same structure as your project. You could in fact create a project from that template, go to Compile, click on “Save…” in the Compile sheet and save the compile settings from that test project as a preset, then go to your current project, go to the Compile sheet, click “Load…” and load the presets you just saved - this will allow your current project to use the same Compile settings as those used in the “Novel (with Parts)” template project - you’ll still need to add the extra spacing around the hash character if you want, though, although isn’t it unusual to have two blank lines either side of it? It can be done if you want, though, as MimeticMouton explained.

All the best,

I finally had a little time to try both the excellent suggestions for “part” breaks, but neither worked… although it looked like it should’ve. Particularly bemused as to why Keith’s suggestion didn’t work - the output is fine, chapters where they should be, but no “part” breaks appear in the output PDF. I will investigate further when I get another 30 seconds to breathe. Day job + novel writing + …er… world of warcraft = zero time.

The compile settings for the “Novel (with Parts)” template don’t set the “parts” folder title on a separate page, so if that’s the only problem then you need to go add the page breaks in the content pane. (Check the box for a page break for each “part” folder, to set it off from the previous page, and then check the box for whatever document immediately follows each part folder, to add a page break between the part folder and the following document.)

Other than the breaks, are the titles, prefixes (the template compile settings will also add a "Part n prefix to the title of your parts folder), etc. coming out the way you expect?

I actually forgot my writing laptop at home today. Clearly I need a holiday. Will try that out tomorrow!